devel/tex-l3kernel - The NetBSD Packages Collection

LaTeX3 programming conventions

The l3kernel bundle provides an implementation of the LaTeX3
programmers' interface, as a set of packages that run under
LaTeX2e. The interface provides the foundation on which the
LaTeX3 kernel and other future code are built: it is an API for
TeX programmers. The packages are set up so that the LaTeX3
conventions can be used with regular LaTeX2e packages.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

print/tex-booktabs print/tex-colortbl print/tex-enumitem print/tex-etex-pkg print/tex-fancyvrb print/tex-graphics devel/tex-l3backend print/tex-latex fonts/tex-lm print/tex-oberdiek fonts/tex-psnfss print/tex-tools print/tex-underscore print/kpathsea

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftex-l3kernel-2021.tgz
NetBSD 8.0earmv7hftex-l3kernel-2020.57669nb1.tgz
NetBSD 8.0earmv7hftex-l3kernel-2021.tgz
NetBSD 8.0i386tex-l3kernel-2020.57669nb1.tgz
NetBSD 8.0i386tex-l3kernel-2021.tgz
NetBSD 8.0powerpctex-l3kernel-2020.57669nb1.tgz
NetBSD 8.0powerpctex-l3kernel-2021.tgz
NetBSD 8.0powerpctex-l3kernel-2021.tgz
NetBSD 8.0powerpctex-l3kernel-2021.tgz
NetBSD 8.0x86_64tex-l3kernel-2020.57669nb1.tgz
NetBSD 8.0x86_64tex-l3kernel-2021.tgz
NetBSD 9.0aarch64tex-l3kernel-2021.tgz
NetBSD 9.0aarch64tex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0aarch64tex-l3kernel-2021.tgz
NetBSD 9.0earmtex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0earmtex-l3kernel-2021.tgz
NetBSD 9.0earmtex-l3kernel-2021.tgz
NetBSD 9.0earmv6hftex-l3kernel-2021.tgz
NetBSD 9.0earmv6hftex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0earmv6hftex-l3kernel-2021.tgz
NetBSD 9.0earmv7hftex-l3kernel-2021.tgz
NetBSD 9.0earmv7hftex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0earmv7hftex-l3kernel-2021.tgz
NetBSD 9.0earmv7hftex-l3kernel-2021.tgz
NetBSD 9.0i386tex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0i386tex-l3kernel-2021.tgz
NetBSD 9.0i386tex-l3kernel-2021.tgz
NetBSD 9.0m68ktex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0m68ktex-l3kernel-2021.tgz
NetBSD 9.0mips64ebtex-l3kernel-2021.tgz
NetBSD 9.0mips64ebtex-l3kernel-2021.tgz
NetBSD 9.0mipseltex-l3kernel-2021.tgz
NetBSD 9.0mipseltex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0mipseltex-l3kernel-2021.tgz
NetBSD 9.0powerpctex-l3kernel-2021.tgz
NetBSD 9.0powerpctex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0powerpctex-l3kernel-2021.tgz
NetBSD 9.0powerpctex-l3kernel-2021.tgz
NetBSD 9.0sh3eltex-l3kernel-2021.tgz
NetBSD 9.0sh3eltex-l3kernel-2021.tgz
NetBSD 9.0sparc64tex-l3kernel-2021.tgz
NetBSD 9.0sparc64tex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0sparc64tex-l3kernel-2021.tgz
NetBSD 9.0sparctex-l3kernel-2021.tgz
NetBSD 9.0sparctex-l3kernel-2021.tgz
NetBSD 9.0x86_64tex-l3kernel-2021.tgz
NetBSD 9.0x86_64tex-l3kernel-2021.tgz
NetBSD 9.0x86_64tex-l3kernel-2020.57669nb1.tgz
NetBSD 9.0x86_64tex-l3kernel-2021.tgz
NetBSD 9.0x86_64tex-l3kernel-2021.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.