devel/meld - The NetBSD Packages Collection

Visual diff and merge tool

Meld is a visual diff and merge tool. You can compare two or three
files and edit them in place (diffs update dynamically). You can
compare two or three folders and launch file comparisons. You can
browse and view a working copy from popular version control systems
such such as CVS, Subversion, Bazaar-ng and Mercurial.

Build dependencies

devel/py-distro pkgtools/x11-links devel/py-gobject3-common x11/xcb-proto x11/xorgproto pkgtools/cwrappers devel/glib2-tools textproc/intltool textproc/itstool devel/gettext-tools lang/perl5 devel/pkgconf

Runtime dependencies

devel/py-gobject3 sysutils/gsettings-desktop-schemas devel/dconf-editor graphics/adwaita-icon-theme graphics/hicolor-icon-theme graphics/py-cairo graphics/py-cairo sysutils/desktop-file-utils devel/glib2 devel/glib2 x11/gtk3 x11/gtk3 x11/gtksourceview4 graphics/hicolor-icon-theme graphics/py-cairo sysutils/desktop-file-utils devel/glib2 x11/gtk3 x11/gtksourceview4

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmeld-3.21.0nb8.tgz
NetBSD 8.0earmv7hfmeld-3.21.0nb7.tgz
NetBSD 8.0earmv7hfmeld-3.21.0nb8.tgz
NetBSD 8.0i386meld-3.21.0nb7.tgz
NetBSD 8.0i386meld-3.21.0nb8.tgz
NetBSD 8.0x86_64meld-3.21.0nb7.tgz
NetBSD 8.0x86_64meld-3.21.0nb8.tgz
NetBSD 9.0aarch64meld-3.21.0nb8.tgz
NetBSD 9.0aarch64meld-3.21.0nb7.tgz
NetBSD 9.0aarch64meld-3.21.0nb8.tgz
NetBSD 9.0alphameld-3.21.0nb8.tgz
NetBSD 9.0alphameld-3.21.0nb8.tgz
NetBSD 9.0earmv6hfmeld-3.21.0nb8.tgz
NetBSD 9.0earmv6hfmeld-3.21.0nb7.tgz
NetBSD 9.0earmv6hfmeld-3.21.0nb8.tgz
NetBSD 9.0earmv7hfmeld-3.21.0nb8.tgz
NetBSD 9.0earmv7hfmeld-3.21.0nb7.tgz
NetBSD 9.0earmv7hfmeld-3.21.0nb8.tgz
NetBSD 9.0earmv7hfmeld-3.21.0nb8.tgz
NetBSD 9.0i386meld-3.21.0nb7.tgz
NetBSD 9.0i386meld-3.21.0nb8.tgz
NetBSD 9.0i386meld-3.21.0nb8.tgz
NetBSD 9.0mips64ebmeld-3.21.0nb8.tgz
NetBSD 9.0mips64ebmeld-3.21.0nb7.tgz
NetBSD 9.0mips64ebmeld-3.21.0nb7.tgz
NetBSD 9.0mips64ebmeld-3.21.0nb8.tgz
NetBSD 9.0sparc64meld-3.21.0nb8.tgz
NetBSD 9.0sparc64meld-3.21.0nb7.tgz
NetBSD 9.0sparc64meld-3.21.0nb8.tgz
NetBSD 9.0x86_64meld-3.21.0nb8.tgz
NetBSD 9.0x86_64meld-3.21.0nb8.tgz
NetBSD 9.0x86_64meld-3.21.0nb7.tgz
NetBSD 9.0x86_64meld-3.21.0nb8.tgz
NetBSD 9.0x86_64meld-3.21.0nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.