sysutils/virt-viewer - The NetBSD Packages Collection

Graphical VNC/SPice viewer for the guest OS

Virt Viewer provides a graphical viewer for the guest OS
display. At this time is supports guest OS using the VNC
or SPICE protocols. Further protocols may be supported in
the future as user demand dictates. The viewer can connect
directly to both local and remotely hosted guest OS, optionally
using SSL/TLS encryption.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto sysutils/spice-protocol pkgtools/cwrappers devel/glib2-tools textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

devel/glib2 graphics/hicolor-icon-theme net/gtk-vnc x11/gtk3 security/libgcrypt security/libgpg-error sysutils/spice-gtk textproc/libxml2 devel/glib2 graphics/hicolor-icon-theme net/gtk-vnc x11/gtk3 security/libgcrypt security/libgpg-error sysutils/spice-gtk textproc/libxml2

Binary packages

OSArchitectureVersion
NetBSD 8.0powerpcvirt-viewer-8.0nb8.tgz
NetBSD 8.0x86_64virt-viewer-8.0nb8.tgz
NetBSD 9.0aarch64virt-viewer-8.0nb8.tgz
NetBSD 9.0aarch64virt-viewer-8.0nb6.tgz
NetBSD 9.0aarch64virt-viewer-8.0nb8.tgz
NetBSD 9.0alphavirt-viewer-8.0nb8.tgz
NetBSD 9.0earmv6hfvirt-viewer-8.0nb8.tgz
NetBSD 9.0earmv7hfvirt-viewer-8.0nb8.tgz
NetBSD 9.0earmv7hfvirt-viewer-8.0nb8.tgz
NetBSD 9.0i386virt-viewer-8.0nb6.tgz
NetBSD 9.0i386virt-viewer-8.0nb8.tgz
NetBSD 9.0powerpcvirt-viewer-8.0nb6.tgz
NetBSD 9.0powerpcvirt-viewer-8.0nb8.tgz
NetBSD 9.0sparc64virt-viewer-8.0nb8.tgz
NetBSD 9.0sparc64virt-viewer-8.0nb6.tgz
NetBSD 9.0sparc64virt-viewer-8.0nb8.tgz
NetBSD 9.0x86_64virt-viewer-8.0nb8.tgz
NetBSD 9.0x86_64virt-viewer-8.0nb8.tgz
NetBSD 9.0x86_64virt-viewer-8.0nb6.tgz
NetBSD 9.0x86_64virt-viewer-8.0nb8.tgz
NetBSD 9.0x86_64virt-viewer-8.0nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.