textproc/intltool - The NetBSD Packages Collection

Internationalization Tool Collection

The intltool collection can be used to do these things:

 o Extract translatable strings from various source files (.xml.in,
   .glade, .desktop.in, .server.in, .oaf.in).

 o Collect the extracted strings together with messages from traditional
   source files (.c, .h) in po/$(PACKAGE).pot.

 o Merge back the translations from .po files into .xml, .desktop and
   .oaf files.  This merge step will happen at build resp. installation
   time.

The intltool package has a script, intltoolize, which copies the various
scripts and does the other magic to your module. So users building
from tarballs don't need intltool, only folks building from cvs.
(This is modelled on gettextize.)

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

textproc/p5-XML-Parser lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 8.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 8.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 8.0earmv7hfintltool-0.51.0nb6.tgz
NetBSD 8.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 8.0i386intltool-0.51.0nb5.tgz
NetBSD 8.0i386intltool-0.51.0nb5.tgz
NetBSD 8.0i386intltool-0.51.0nb5.tgz
NetBSD 8.0i386intltool-0.51.0nb6.tgz
NetBSD 8.0powerpcintltool-0.51.0nb5.tgz
NetBSD 8.0powerpcintltool-0.51.0nb5.tgz
NetBSD 8.0powerpcintltool-0.51.0nb5.tgz
NetBSD 8.0powerpcintltool-0.51.0nb5.tgz
NetBSD 8.0x86_64intltool-0.51.0nb5.tgz
NetBSD 8.0x86_64intltool-0.51.0nb5.tgz
NetBSD 8.0x86_64intltool-0.51.0nb5.tgz
NetBSD 8.0x86_64intltool-0.51.0nb6.tgz
NetBSD 9.0aarch64intltool-0.51.0nb6.tgz
NetBSD 9.0aarch64intltool-0.51.0nb5.tgz
NetBSD 9.0aarch64intltool-0.51.0nb5.tgz
NetBSD 9.0aarch64intltool-0.51.0nb5.tgz
NetBSD 9.0alphaintltool-0.51.0nb5.tgz
NetBSD 9.0alphaintltool-0.51.0nb6.tgz
NetBSD 9.0earmintltool-0.51.0nb5.tgz
NetBSD 9.0earmintltool-0.51.0nb6.tgz
NetBSD 9.0earmv6hfintltool-0.51.0nb6.tgz
NetBSD 9.0earmv6hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv6hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv6hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv6hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb6.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb6.tgz
NetBSD 9.0earmv7hfintltool-0.51.0nb5.tgz
NetBSD 9.0i386intltool-0.51.0nb5.tgz
NetBSD 9.0i386intltool-0.51.0nb5.tgz
NetBSD 9.0i386intltool-0.51.0nb5.tgz
NetBSD 9.0i386intltool-0.51.0nb6.tgz
NetBSD 9.0m68kintltool-0.51.0nb5.tgz
NetBSD 9.0m68kintltool-0.51.0nb5.tgz
NetBSD 9.0m68kintltool-0.51.0nb6.tgz
NetBSD 9.0mips64ebintltool-0.51.0nb5.tgz
NetBSD 9.0mips64ebintltool-0.51.0nb5.tgz
NetBSD 9.0mips64ebintltool-0.51.0nb5.tgz
NetBSD 9.0mips64ebintltool-0.51.0nb6.tgz
NetBSD 9.0mipselintltool-0.51.0nb5.tgz
NetBSD 9.0mipselintltool-0.51.0nb5.tgz
NetBSD 9.0mipselintltool-0.51.0nb6.tgz
NetBSD 9.0powerpcintltool-0.51.0nb5.tgz
NetBSD 9.0powerpcintltool-0.51.0nb5.tgz
NetBSD 9.0powerpcintltool-0.51.0nb5.tgz
NetBSD 9.0powerpcintltool-0.51.0nb5.tgz
NetBSD 9.0powerpcintltool-0.51.0nb5.tgz
NetBSD 9.0sh3elintltool-0.51.0nb5.tgz
NetBSD 9.0sh3elintltool-0.51.0nb5.tgz
NetBSD 9.0sh3elintltool-0.51.0nb5.tgz
NetBSD 9.0sh3elintltool-0.51.0nb6.tgz
NetBSD 9.0sparc64intltool-0.51.0nb5.tgz
NetBSD 9.0sparc64intltool-0.51.0nb6.tgz
NetBSD 9.0sparcintltool-0.51.0nb5.tgz
NetBSD 9.0sparcintltool-0.51.0nb5.tgz
NetBSD 9.0sparcintltool-0.51.0nb5.tgz
NetBSD 9.0sparcintltool-0.51.0nb6.tgz
NetBSD 9.0vaxintltool-0.51.0nb5.tgz
NetBSD 9.0vaxintltool-0.51.0nb5.tgz
NetBSD 9.0vaxintltool-0.51.0nb5.tgz
NetBSD 9.0vaxintltool-0.51.0nb6.tgz
NetBSD 9.0x86_64intltool-0.51.0nb5.tgz
NetBSD 9.0x86_64intltool-0.51.0nb6.tgz
NetBSD 9.0x86_64intltool-0.51.0nb5.tgz
NetBSD 9.0x86_64intltool-0.51.0nb6.tgz
NetBSD 9.0x86_64intltool-0.51.0nb5.tgz
NetBSD 9.0x86_64intltool-0.51.0nb5.tgz
NetBSD 9.0x86_64intltool-0.51.0nb5.tgz
NetBSD 9.0x86_64intltool-0.51.0nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.