Daemon Power

The NetBSD Packages Collection: security/polkit

Brief description of the package:
Authorization Manager

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.freedesktop.org/wiki/Software/polkit.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "security/polkit" directory. The current source version of the package is "polkit-0.118". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for security/polkit :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: glib2>=2.4.0 pcre>=3.4nb1 cwrappers>=20150314 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools-[0-9]* py37-expat-[0-9]* python37>=3.7.9 mozjs78>=78.3.0 icu>=3.4 icu>=68.1 clang>=9.0.1 llvm-10.0.1{,nb*} libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb3 perl>=5.0 llvm>=10.0.1 rust>=1.41.0 curl>=7.67.0 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 nghttp2>=1.40.0nb4 curl>=7.12.3 curl>=7.70.0nb2 rust>=1.20.0 clang>=10.0.1nb2 glib2>=2.64.0nb1 libxslt-[0-9]* libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gobject-introspection>=1.62.0nb1 .

This package requires the following package(s) to run: glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 mozjs78>=78.3.0 icu>=3.4 icu>=68.1 glib2>=2.64.0nb1 .

This package supports the following build-time options:

introspection
Enable GObject Introspection support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:polkit-0.116nb4.tgz(NetBSD 9.0)
aarch64:polkit-0.116nb3.tgz(NetBSD 9.0)
alpha:polkit-0.116nb3.tgz(NetBSD 9.0)
alpha:polkit-0.116nb4.tgz(NetBSD 9.0)
earmv7hf:polkit-0.116nb3.tgz(NetBSD 8.0)
earmv7hf:polkit-0.115nb4.tgz(NetBSD 8.0)
earmv7hf:polkit-0.116nb4.tgz(NetBSD 8.0)
earmv7hf:polkit-0.116nb3.tgz(NetBSD 9.0)
earmv7hf:polkit-0.115nb4.tgz(NetBSD 9.0)
earmv7hf:polkit-0.116nb4.tgz(NetBSD 9.0)
i386:polkit-0.116nb4.tgz(NetBSD 8.0)
i386:polkit-0.116nb3.tgz(NetBSD 8.0)
i386:polkit-0.116nb4.tgz(NetBSD 9.0)
i386:polkit-0.116nb3.tgz(NetBSD 9.0)
powerpc:polkit-0.116nb4.tgz(NetBSD 8.0)
powerpc:polkit-0.116nb3.tgz(NetBSD 9.0)
sparc64:polkit-0.116nb4.tgz(NetBSD 9.0)
sparc64:polkit-0.116nb3.tgz(NetBSD 9.0)
x86_64:polkit-0.118.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb3.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb4.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb4.tgz(NetBSD 8.0)
x86_64:polkit-0.116nb3.tgz(NetBSD 8.0)
x86_64:polkit-0.116nb4.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb3.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]