inputmethod/uim - The NetBSD Packages Collection

Multilingual input method library

Uim is a lightweight and full featured multilingual input method library
and is simple, secure and flexible.

Supported languages:
Japanese, Chinese(PinYin), Korean, Vietnamese

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto lang/ruby26-base pkgtools/cwrappers graphics/librsvg devel/glib2-tools devel/libtool-base devel/automake devel/autoconf textproc/intltool devel/gettext-tools devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

x11/gtk2 fonts/Xft2 fonts/Xft2 fonts/Xft2 x11/gtk3 x11/qt5-qtx11extras devel/libgcroots devel/libgcroots inputmethod/anthy x11/gtk2 fonts/Xft2 x11/gtk3 x11/qt5-qtx11extras inputmethod/anthy

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfuim-1.8.8nb7.tgz
NetBSD 8.0earmv7hfuim-1.8.8nb7.tgz
NetBSD 8.0i386uim-1.8.8nb6.tgz
NetBSD 8.0i386uim-1.8.8nb7.tgz
NetBSD 8.0i386uim-1.8.8nb7.tgz
NetBSD 8.0powerpcuim-1.8.8nb6.tgz
NetBSD 8.0powerpcuim-1.8.8nb7.tgz
NetBSD 8.0powerpcuim-1.8.8nb7.tgz
NetBSD 8.0powerpcuim-1.8.8nb7.tgz
NetBSD 8.0x86_64uim-1.8.8nb7.tgz
NetBSD 8.0x86_64uim-1.8.8nb6.tgz
NetBSD 8.0x86_64uim-1.8.8nb7.tgz
NetBSD 9.0aarch64uim-1.8.8nb7.tgz
NetBSD 9.0aarch64uim-1.8.8nb6.tgz
NetBSD 9.0aarch64uim-1.8.8nb7.tgz
NetBSD 9.0alphauim-1.8.8nb7.tgz
NetBSD 9.0alphauim-1.8.8nb6.tgz
NetBSD 9.0alphauim-1.8.8nb7.tgz
NetBSD 9.0earmuim-1.8.8nb7.tgz
NetBSD 9.0earmv6hfuim-1.8.8nb7.tgz
NetBSD 9.0earmv6hfuim-1.8.8nb6.tgz
NetBSD 9.0earmv6hfuim-1.8.8nb7.tgz
NetBSD 9.0earmv6hfuim-1.8.8nb7.tgz
NetBSD 9.0earmv7hfuim-1.8.8nb7.tgz
NetBSD 9.0earmv7hfuim-1.8.8nb6.tgz
NetBSD 9.0earmv7hfuim-1.8.8nb7.tgz
NetBSD 9.0earmv7hfuim-1.8.8nb7.tgz
NetBSD 9.0earmv7hfuim-1.8.8nb7.tgz
NetBSD 9.0i386uim-1.8.8nb6.tgz
NetBSD 9.0i386uim-1.8.8nb7.tgz
NetBSD 9.0i386uim-1.8.8nb7.tgz
NetBSD 9.0mips64ebuim-1.8.8nb7.tgz
NetBSD 9.0mips64ebuim-1.8.8nb6.tgz
NetBSD 9.0mips64ebuim-1.8.8nb7.tgz
NetBSD 9.0powerpcuim-1.8.8nb7.tgz
NetBSD 9.0powerpcuim-1.8.8nb6.tgz
NetBSD 9.0powerpcuim-1.8.8nb7.tgz
NetBSD 9.0powerpcuim-1.8.8nb7.tgz
NetBSD 9.0sparc64uim-1.8.8nb7.tgz
NetBSD 9.0sparc64uim-1.8.8nb5.tgz
NetBSD 9.0sparc64uim-1.8.8nb6.tgz
NetBSD 9.0sparc64uim-1.8.8nb7.tgz
NetBSD 9.0x86_64uim-1.8.8nb7.tgz
NetBSD 9.0x86_64uim-1.8.8nb7.tgz
NetBSD 9.0x86_64uim-1.8.8nb7.tgz
NetBSD 9.0x86_64uim-1.8.8nb7.tgz
NetBSD 9.0x86_64uim-1.8.8nb6.tgz
NetBSD 9.0x86_64uim-1.8.8nb7.tgz
NetBSD 9.0x86_64uim-1.8.8nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gtk2
Enable support for GTK2.
gtk3
Enable support for GTK3.
qt5
Enable support for QT5.
xim
Enable X Input Method support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.