graphics/kipi-plugins - The NetBSD Packages Collection

Collection of plugins extending the KDE graphics and image applications

KIPI (KDE Image Plugin Interface) is an effort to develop a common
plugin structure for Digikam, KPhotoAlbum, Showimg and GwenView.
Its aim is to share image plugins among graphic applications. Kipi
is based on the old digiKam plugins implementation.

One of the nicest things about KDE Photo Management Programs like
"digiKam", "KPhotoAlbum", "GwenView" and "ShowImg" is how easily
its functionality can be extended, by using plugins. Plugins can
manipulate image files in almost any way that users can. Their
advantage is that it is much easier to add a capability to the host
application by writing a small plugin than by modifying the host
application core. Many valuable plugins have C++ source code that
only comes to 100-200 lines or so.

Kipi plugins are additional functions for the KDE Images Managment
Host Programs. They can add extra menus and shortcuts, and extend
the host programs features. You can install as many or as few as
you like, from within host programs.

Build dependencies

devel/extra-cmake-modules pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/pkgconf

Runtime dependencies

security/gnupg2 devel/kio x11/qt5-qtbase x11/kxmlgui graphics/hicolor-icon-theme graphics/libkipi misc/libkvkontakte www/libmediawiki devel/kio x11/qt5-qtbase x11/kxmlgui graphics/hicolor-icon-theme graphics/libkipi misc/libkvkontakte www/libmediawiki

Binary packages

OSArchitectureVersion
NetBSD 8.0i386kipi-plugins-20.04.1nb2.tgz
NetBSD 8.0x86_64kipi-plugins-20.04.1nb6.tgz
NetBSD 8.0x86_64kipi-plugins-20.04.1nb2.tgz
NetBSD 8.0x86_64kipi-plugins-20.04.1nb4.tgz
NetBSD 9.0aarch64kipi-plugins-20.04.1nb2.tgz
NetBSD 9.0aarch64kipi-plugins-20.04.1nb4.tgz
NetBSD 9.0i386kipi-plugins-20.04.1nb2.tgz
NetBSD 9.0i386kipi-plugins-20.04.1nb4.tgz
NetBSD 9.0i386kipi-plugins-20.04.1nb6.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb3.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb5.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb5.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb6.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb2.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb4.tgz
NetBSD 9.0x86_64kipi-plugins-20.04.1nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.