security/gnupg2 - The NetBSD Packages Collection

GnuPG with OpenPGP and S/MIME capabilities

GnuPG 2.2 provides several utilities that are used by mail clients,
such as Kmail and Balsa, including OpenPGP and S/MIME support.  GnuPG
2.2 has a different architecture than GnuPG 1.4 in that it splits up
functionality into several modules.  However, both versions may be
installed alongside without any conflict.  The advantage of GnuPG-1 is
its smaller size and the lack of dependency on other modules at run
and build time.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

security/pinentry security/gnutls devel/libusb1 devel/npth devel/npth devel/readline security/libgcrypt security/libgcrypt security/libgpg-error security/libgpg-error security/libassuan2 security/libassuan2 security/libksba security/libksba security/gnutls devel/readline security/libgcrypt security/libgpg-error security/libksba

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgnupg2-2.2.25.tgz
NetBSD 8.0earmv7hfgnupg2-2.2.23.tgz
NetBSD 8.0earmv7hfgnupg2-2.2.27.tgz
NetBSD 8.0earmv7hfgnupg2-2.2.27nb2.tgz
NetBSD 8.0i386gnupg2-2.2.23.tgz
NetBSD 8.0i386gnupg2-2.2.25.tgz
NetBSD 8.0i386gnupg2-2.2.27.tgz
NetBSD 8.0i386gnupg2-2.2.27nb2.tgz
NetBSD 8.0powerpcgnupg2-2.2.23.tgz
NetBSD 8.0powerpcgnupg2-2.2.27.tgz
NetBSD 8.0powerpcgnupg2-2.2.25.tgz
NetBSD 8.0powerpcgnupg2-2.2.27.tgz
NetBSD 8.0x86_64gnupg2-2.2.27.tgz
NetBSD 8.0x86_64gnupg2-2.2.23.tgz
NetBSD 8.0x86_64gnupg2-2.2.25.tgz
NetBSD 8.0x86_64gnupg2-2.2.27nb2.tgz
NetBSD 9.0aarch64gnupg2-2.2.27nb2.tgz
NetBSD 9.0aarch64gnupg2-2.2.23.tgz
NetBSD 9.0aarch64gnupg2-2.2.25.tgz
NetBSD 9.0aarch64gnupg2-2.2.27.tgz
NetBSD 9.0alphagnupg2-2.2.27.tgz
NetBSD 9.0alphagnupg2-2.2.27nb2.tgz
NetBSD 9.0earmgnupg2-2.2.27.tgz
NetBSD 9.0earmgnupg2-2.2.27nb2.tgz
NetBSD 9.0earmv6hfgnupg2-2.2.27nb2.tgz
NetBSD 9.0earmv6hfgnupg2-2.2.23.tgz
NetBSD 9.0earmv6hfgnupg2-2.2.25.tgz
NetBSD 9.0earmv6hfgnupg2-2.2.25.tgz
NetBSD 9.0earmv6hfgnupg2-2.2.27.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.27nb2.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.23.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.25.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.25.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.27.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.27.tgz
NetBSD 9.0earmv7hfgnupg2-2.2.27nb2.tgz
NetBSD 9.0i386gnupg2-2.2.23.tgz
NetBSD 9.0i386gnupg2-2.2.25.tgz
NetBSD 9.0i386gnupg2-2.2.27.tgz
NetBSD 9.0i386gnupg2-2.2.27nb2.tgz
NetBSD 9.0m68kgnupg2-2.2.27.tgz
NetBSD 9.0m68kgnupg2-2.2.23.tgz
NetBSD 9.0mips64ebgnupg2-2.2.27.tgz
NetBSD 9.0mips64ebgnupg2-2.2.23.tgz
NetBSD 9.0mips64ebgnupg2-2.2.25.tgz
NetBSD 9.0mips64ebgnupg2-2.2.27nb2.tgz
NetBSD 9.0mipselgnupg2-2.2.25.tgz
NetBSD 9.0mipselgnupg2-2.2.27.tgz
NetBSD 9.0mipselgnupg2-2.2.27nb2.tgz
NetBSD 9.0powerpcgnupg2-2.2.25.tgz
NetBSD 9.0powerpcgnupg2-2.2.23.tgz
NetBSD 9.0powerpcgnupg2-2.2.27.tgz
NetBSD 9.0powerpcgnupg2-2.2.27.tgz
NetBSD 9.0powerpcgnupg2-2.2.27.tgz
NetBSD 9.0sh3elgnupg2-2.2.23.tgz
NetBSD 9.0sh3elgnupg2-2.2.25.tgz
NetBSD 9.0sh3elgnupg2-2.2.27.tgz
NetBSD 9.0sh3elgnupg2-2.2.27nb2.tgz
NetBSD 9.0sparc64gnupg2-2.2.27.tgz
NetBSD 9.0sparc64gnupg2-2.2.27nb2.tgz
NetBSD 9.0sparcgnupg2-2.2.27.tgz
NetBSD 9.0sparcgnupg2-2.2.23.tgz
NetBSD 9.0sparcgnupg2-2.2.25.tgz
NetBSD 9.0sparcgnupg2-2.2.27nb2.tgz
NetBSD 9.0vaxgnupg2-2.2.25.tgz
NetBSD 9.0x86_64gnupg2-2.2.27.tgz
NetBSD 9.0x86_64gnupg2-2.2.27nb2.tgz
NetBSD 9.0x86_64gnupg2-2.2.27.tgz
NetBSD 9.0x86_64gnupg2-2.2.27nb2.tgz
NetBSD 9.0x86_64gnupg2-2.2.23.tgz
NetBSD 9.0x86_64gnupg2-2.2.25.tgz
NetBSD 9.0x86_64gnupg2-2.2.27.tgz
NetBSD 9.0x86_64gnupg2-2.2.27nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

bzip2
Enable compression using bzip2.
gnutls
Enable GNU TLS support.
ldap
Enable LDAP support.
libusb-1
Enable USB access via libusb-1.
zlib
Enable support for zlib compression.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.