games/kubrick - The NetBSD Packages Collection

Game based on the Rubik's Cube puzzle

kubrick is a game based on the Rubik's Cube puzzle.
The cube sizes range from 2x2x2 up to 6x6x6, or you can play with
irregular bricks such as 5x3x2 or mats such as 6x4x1 or 2x2x1.  The
game has a selection of puzzles at several levels of difficulty, as
well as demos of pretty patterns and solution moves, or you can
make up your own puzzles

Build dependencies

devel/extra-cmake-modules devel/kdoctools pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake

Runtime dependencies

security/gnupg2 games/libkdegames x11/qt5-qtbase graphics/hicolor-icon-theme sysutils/desktop-file-utils games/libkdegames x11/qt5-qtbase graphics/hicolor-icon-theme sysutils/desktop-file-utils

Binary packages

OSArchitectureVersion
NetBSD 8.0i386kubrick-20.04.1nb2.tgz
NetBSD 8.0powerpckubrick-20.04.1nb2.tgz
NetBSD 8.0powerpckubrick-20.04.1nb6.tgz
NetBSD 8.0powerpckubrick-20.04.1nb6.tgz
NetBSD 8.0x86_64kubrick-20.04.1nb6.tgz
NetBSD 8.0x86_64kubrick-20.04.1nb2.tgz
NetBSD 8.0x86_64kubrick-20.04.1nb4.tgz
NetBSD 9.0aarch64kubrick-20.04.1nb6.tgz
NetBSD 9.0aarch64kubrick-20.04.1nb2.tgz
NetBSD 9.0aarch64kubrick-20.04.1nb4.tgz
NetBSD 9.0earmv7hfkubrick-20.04.1nb2.tgz
NetBSD 9.0i386kubrick-20.04.1nb2.tgz
NetBSD 9.0i386kubrick-20.04.1nb4.tgz
NetBSD 9.0i386kubrick-20.04.1nb6.tgz
NetBSD 9.0powerpckubrick-20.04.1nb4.tgz
NetBSD 9.0sparc64kubrick-20.04.1nb6.tgz
NetBSD 9.0sparc64kubrick-20.04.1.tgz
NetBSD 9.0sparc64kubrick-20.04.1nb2.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb3.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb5.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb5.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb6.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb2.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb4.tgz
NetBSD 9.0x86_64kubrick-20.04.1nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.