chat/hexchat - The NetBSD Packages Collection

IRC client based on XChat

HexChat is an IRC client based on XChat, but unlike XChat it's completely
free for both Windows and Unix-like systems. Since XChat is open source, it's
perfectly legal. HexChat was originally called XChat-WDK which in turn was a
successor of freakschat.

Build dependencies

devel/meson pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools lang/python38 devel/gettext-tools devel/pkgconf

Runtime dependencies

graphics/hicolor-icon-theme sysutils/desktop-file-utils graphics/gdk-pixbuf2 devel/glib2 x11/gtk2 devel/pango www/libproxy textproc/iso-codes textproc/libxml2 graphics/hicolor-icon-theme sysutils/desktop-file-utils graphics/gdk-pixbuf2 devel/glib2 x11/gtk2 devel/pango www/libproxy textproc/libxml2

Available binary packages

aarch64:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
aarch64:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
aarch64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
earmv6hf:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
earmv6hf:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
earmv6hf:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
earmv6hf:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
earmv7hf:hexchat-2.14.3nb7.tgz(NetBSD 8.0)
earmv7hf:hexchat-2.14.3nb3.tgz(NetBSD 8.0)
earmv7hf:hexchat-2.14.3nb4.tgz(NetBSD 8.0)
earmv7hf:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
earmv7hf:hexchat-2.14.3nb3.tgz(NetBSD 9.0)
earmv7hf:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
earmv7hf:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
earmv7hf:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
i386:hexchat-2.14.3nb4.tgz(NetBSD 8.0)
i386:hexchat-2.14.3nb6.tgz(NetBSD 8.0)
i386:hexchat-2.14.3nb7.tgz(NetBSD 8.0)
i386:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
i386:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
i386:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
mips64eb:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
mips64eb:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
powerpc:hexchat-2.14.3nb4.tgz(NetBSD 8.0)
powerpc:hexchat-2.14.3nb6.tgz(NetBSD 8.0)
powerpc:hexchat-2.14.3nb7.tgz(NetBSD 8.0)
powerpc:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
powerpc:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
powerpc:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
sparc64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
sparc64:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
sparc64:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
sparc:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
sparc:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
sparc:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb6.tgz(NetBSD 8.0)
x86_64:hexchat-2.14.3nb4.tgz(NetBSD 8.0)
x86_64:hexchat-2.14.3nb7.tgz(NetBSD 8.0)
x86_64:hexchat-2.14.3nb4.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb6.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)
x86_64:hexchat-2.14.3nb7.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

dbus
Enable dbus (desktop bus) support.
gtk2
Enable support for GTK2.
libcanberra
libnotify
Enable libnotify support.
libpci
libproxy
lua
Enable Lua support.
openssl
Enable OpenSSL support.
perl
Enable Perl support.
python
Enable Python support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]