audio/gqmpeg-devel - The NetBSD Packages Collection

GTK+ front end to mpg123

GQmpeg is a frontend to mpg123 with extensive themeability and playlist
support.

Features:
    - Extensive mpg123 option support.
    - Shuffle, repeat.
    - Shuffle and repeat preferences can be saved in each playlist.
    - Customizable skins, including winamp skin support.
    - A skin can contain an alternative face (shade mode for instance)
    - ID3 tag reading/writing support (v1)
    - Volume controls (can be connected to any available device)
    - Basic file management (move/copy/rename/delete)
    - Tab completion in most dialogs.
    - Presets for playlists.
    - Drag and drop support.
    - Shoutcast (http://server:port) support.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto devel/glib2-tools pkgtools/mktools devel/pkgconf pkgtools/cwrappers

Runtime dependencies

audio/mpg123 audio/vorbis-tools audio/xmp x11/gtk2 x11/gtk2

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64gqmpeg-0.91.1nb40.tgz
NetBSD 10.0aarch64gqmpeg-0.91.1nb40.tgz
NetBSD 10.0earmv6hfgqmpeg-0.91.1nb40.tgz
NetBSD 10.0earmv6hfgqmpeg-0.91.1nb40.tgz
NetBSD 10.0earmv7hfgqmpeg-0.91.1nb40.tgz
NetBSD 10.0earmv7hfgqmpeg-0.91.1nb40.tgz
NetBSD 10.0i386gqmpeg-0.91.1nb40.tgz
NetBSD 10.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 10.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 10.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 10.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 8.0earmv7hfgqmpeg-0.91.1nb39.tgz
NetBSD 8.0i386gqmpeg-0.91.1nb40.tgz
NetBSD 8.0i386gqmpeg-0.91.1nb40.tgz
NetBSD 8.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 8.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 8.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 8.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 8.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0aarch64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0aarch64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0aarch64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0alphagqmpeg-0.91.1nb40.tgz
NetBSD 9.0alphagqmpeg-0.91.1nb40.tgz
NetBSD 9.0alphagqmpeg-0.91.1nb40.tgz
NetBSD 9.0alphagqmpeg-0.91.1nb40.tgz
NetBSD 9.0alphagqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmv6hfgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmv6hfgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmv6hfgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmv7hfgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmv7hfgqmpeg-0.91.1nb40.tgz
NetBSD 9.0earmv7hfgqmpeg-0.91.1nb40.tgz
NetBSD 9.0i386gqmpeg-0.91.1nb40.tgz
NetBSD 9.0i386gqmpeg-0.91.1nb40.tgz
NetBSD 9.0i386gqmpeg-0.91.1nb40.tgz
NetBSD 9.0mips64ebgqmpeg-0.91.1nb40.tgz
NetBSD 9.0mips64ebgqmpeg-0.91.1nb40.tgz
NetBSD 9.0mips64ebgqmpeg-0.91.1nb40.tgz
NetBSD 9.0mips64ebgqmpeg-0.91.1nb40.tgz
NetBSD 9.0mips64ebgqmpeg-0.91.1nb40.tgz
NetBSD 9.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 9.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 9.0powerpcgqmpeg-0.91.1nb40.tgz
NetBSD 9.0sparc64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0sparc64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0sparc64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0sparc64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0sparc64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0sparcgqmpeg-0.91.1nb39.tgz
NetBSD 9.0sparcgqmpeg-0.91.1nb40.tgz
NetBSD 9.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0x86_64gqmpeg-0.91.1nb40.tgz
NetBSD 9.0x86_64gqmpeg-0.91.1nb40.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gqmpeg-japanese
Japanese ID3 tag support.
gqmpeg-russian
Russian ID3 tag support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.