audio/xmp - The NetBSD Packages Collection

Player for many different Amiga and PC module formats

The Extended Module Player, or xmp, is a portable command-line module
player. Xmp plays many mainstream and obscure module formats including
Protracker (MOD), Scream Tracker 3 (S3M), Fast Tracker II (XM), and
Impulse Tracker (IT).

Build dependencies

devel/gmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

audio/libxmp

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfxmp-4.1.0nb5.tgz
NetBSD 8.0i386xmp-4.1.0nb7.tgz
NetBSD 8.0i386xmp-4.1.0nb7.tgz
NetBSD 8.0powerpcxmp-4.1.0nb5.tgz
NetBSD 8.0powerpcxmp-4.1.0nb6.tgz
NetBSD 8.0x86_64xmp-4.1.0nb7.tgz
NetBSD 8.0x86_64xmp-4.1.0nb7.tgz
NetBSD 9.0aarch64xmp-4.1.0nb7.tgz
NetBSD 9.0aarch64xmp-4.1.0nb7.tgz
NetBSD 9.0alphaxmp-4.1.0nb6.tgz
NetBSD 9.0alphaxmp-4.1.0nb7.tgz
NetBSD 9.0alphaxmp-4.1.0nb7.tgz
NetBSD 9.0earmxmp-4.1.0nb6.tgz
NetBSD 9.0earmxmp-4.1.0nb7.tgz
NetBSD 9.0earmxmp-4.1.0nb7.tgz
NetBSD 9.0earmv6hfxmp-4.1.0nb7.tgz
NetBSD 9.0earmv6hfxmp-4.1.0nb7.tgz
NetBSD 9.0earmv7hfxmp-4.1.0nb7.tgz
NetBSD 9.0earmv7hfxmp-4.1.0nb7.tgz
NetBSD 9.0i386xmp-4.1.0nb7.tgz
NetBSD 9.0i386xmp-4.1.0nb7.tgz
NetBSD 9.0i386xmp-4.1.0nb7.tgz
NetBSD 9.0mips64ebxmp-4.1.0nb6.tgz
NetBSD 9.0mips64ebxmp-4.1.0nb7.tgz
NetBSD 9.0mips64ebxmp-4.1.0nb7.tgz
NetBSD 9.0powerpcxmp-4.1.0nb6.tgz
NetBSD 9.0powerpcxmp-4.1.0nb5.tgz
NetBSD 9.0sh3elxmp-4.1.0nb6.tgz
NetBSD 9.0sh3elxmp-4.1.0nb7.tgz
NetBSD 9.0sh3elxmp-4.1.0nb7.tgz
NetBSD 9.0sparc64xmp-4.1.0nb6.tgz
NetBSD 9.0sparc64xmp-4.1.0nb7.tgz
NetBSD 9.0sparc64xmp-4.1.0nb7.tgz
NetBSD 9.0sparcxmp-4.1.0nb5.tgz
NetBSD 9.0sparcxmp-4.1.0nb6.tgz
NetBSD 9.0sparcxmp-4.1.0nb7.tgz
NetBSD 9.0sparcxmp-4.1.0nb7.tgz
NetBSD 9.0vaxxmp-4.1.0nb7.tgz
NetBSD 9.0vaxxmp-4.1.0nb7.tgz
NetBSD 9.0x86_64xmp-4.1.0nb8.tgz
NetBSD 9.0x86_64xmp-4.1.0nb7.tgz
NetBSD 9.0x86_64xmp-4.1.0nb7.tgz
NetBSD 9.0x86_64xmp-4.1.0nb7.tgz
NetBSD 9.0x86_64xmp-4.1.0nb7.tgz
NetBSD 9.0x86_64xmp-4.1.0nb8.tgz
NetBSD 9.99.96aarch64ebxmp-4.1.0nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

alsa
Enable ALSA support.
pulseaudio
Enable support for the PulseAudio sound server.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.