x11/gtkmm3 - The NetBSD Packages Collection

C++ Interfaces for GTK+ and GNOME (v3)

gtkmm is the official C++ interface for the popular GUI library GTK+. Highlights
include typesafe callbacks, and a comprehensive set of widgets that are easily
extensible via inheritance. You can create user interfaces either in code or
with the Glade User Interface designer, using Gtk::Builder. There's extensive
documentation, including API reference and a tutorial.

This is major version 3 of the library using interfaces for GTK3.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/meson lang/perl5 devel/pkgconf

Runtime dependencies

x11/gtk3 x11/gtk3 graphics/gdk-pixbuf2 graphics/gdk-pixbuf2 devel/atkmm devel/atkmm devel/glibmm devel/glibmm devel/pangomm devel/pangomm graphics/cairomm graphics/cairomm textproc/libxslt x11/gtk3 graphics/gdk-pixbuf2 devel/atkmm devel/glibmm devel/pangomm graphics/cairomm textproc/libxslt

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgtkmm3-3.24.2nb4.tgz
NetBSD 8.0earmv7hfgtkmm3-3.24.2nb3.tgz
NetBSD 8.0earmv7hfgtkmm3-3.24.2nb4.tgz
NetBSD 8.0i386gtkmm3-3.24.2nb3.tgz
NetBSD 8.0i386gtkmm3-3.24.2nb4.tgz
NetBSD 8.0i386gtkmm3-3.24.2nb4.tgz
NetBSD 8.0powerpcgtkmm3-3.24.2nb3.tgz
NetBSD 8.0powerpcgtkmm3-3.24.2nb4.tgz
NetBSD 8.0powerpcgtkmm3-3.24.2nb4.tgz
NetBSD 8.0powerpcgtkmm3-3.24.2nb4.tgz
NetBSD 8.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 8.0x86_64gtkmm3-3.24.2nb3.tgz
NetBSD 8.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0aarch64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0aarch64gtkmm3-3.24.2nb3.tgz
NetBSD 9.0aarch64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0alphagtkmm3-3.24.2nb4.tgz
NetBSD 9.0alphagtkmm3-3.24.2nb3.tgz
NetBSD 9.0alphagtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv6hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv6hfgtkmm3-3.24.2nb3.tgz
NetBSD 9.0earmv6hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv6hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv7hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv7hfgtkmm3-3.24.2nb3.tgz
NetBSD 9.0earmv7hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv7hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0earmv7hfgtkmm3-3.24.2nb4.tgz
NetBSD 9.0i386gtkmm3-3.24.2nb3.tgz
NetBSD 9.0i386gtkmm3-3.24.2nb4.tgz
NetBSD 9.0i386gtkmm3-3.24.2nb4.tgz
NetBSD 9.0mips64ebgtkmm3-3.24.2nb4.tgz
NetBSD 9.0mips64ebgtkmm3-3.24.2nb3.tgz
NetBSD 9.0mips64ebgtkmm3-3.24.2nb4.tgz
NetBSD 9.0mipselgtkmm3-3.24.2nb4.tgz
NetBSD 9.0powerpcgtkmm3-3.24.2nb4.tgz
NetBSD 9.0powerpcgtkmm3-3.24.2nb3.tgz
NetBSD 9.0powerpcgtkmm3-3.24.2nb4.tgz
NetBSD 9.0powerpcgtkmm3-3.24.2nb4.tgz
NetBSD 9.0sh3elgtkmm3-3.24.2nb4.tgz
NetBSD 9.0sh3elgtkmm3-3.24.2nb4.tgz
NetBSD 9.0sparc64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0sparc64gtkmm3-3.24.2nb1.tgz
NetBSD 9.0sparc64gtkmm3-3.24.2nb3.tgz
NetBSD 9.0sparc64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0sparcgtkmm3-3.24.2nb4.tgz
NetBSD 9.0sparcgtkmm3-3.24.2nb3.tgz
NetBSD 9.0sparcgtkmm3-3.24.2nb4.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb3.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb4.tgz
NetBSD 9.0x86_64gtkmm3-3.24.2nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.