textproc/p5-Text-SpellChecker - The NetBSD Packages Collection

Perl5 OO interface for spell-checking a block of text

This module is built on Text::Aspell, but adds some of the
functionality provided by the internal gnu aspell API. This allows
one to deal with blocks of text, rather than just words. For
instance, we provide methods for iterating through the text,
serializing the object (thus remembering where we left off), and
highlighting the current misspelled word within the text.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/p5-Text-Aspell lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 8.0earmv7hfp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 8.0earmv7hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 8.0i386p5-Text-SpellChecker-0.14nb6.tgz
NetBSD 8.0i386p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 8.0powerpcp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 8.0powerpcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 8.0powerpcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 8.0powerpcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 8.0x86_64p5-Text-SpellChecker-0.14nb6.tgz
NetBSD 8.0x86_64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0aarch64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0aarch64p5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0aarch64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0alphap5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0alphap5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0alphap5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0earmv6hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0earmv6hfp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0earmv6hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0earmv7hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0earmv7hfp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0earmv7hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0earmv7hfp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0i386p5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0i386p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0mips64ebp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0mips64ebp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0mips64ebp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0mips64ebp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0mips64ebp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0powerpcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0powerpcp5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0powerpcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0powerpcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0sparc64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0sparc64p5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0sparc64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0sparcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0sparcp5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0x86_64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0x86_64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0x86_64p5-Text-SpellChecker-0.14nb6.tgz
NetBSD 9.0x86_64p5-Text-SpellChecker-0.14nb7.tgz
NetBSD 9.0x86_64p5-Text-SpellChecker-0.14nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.