security/pam-p11 - The NetBSD Packages Collection

Smart card PAM module

Pam_p11 is a plugable authentication module (PAM) package for using
crpytographic PKCS#11 tokens such as smart cards and usb crypto
tokens for local authentication.

Pam_p11 implements two authentication modules:
* pam_p11_openssh authenticates the user against public keys found
in OpenSSH ~/.ssh/authorized_keys file.
* pam_p11_opensc authenticates the user against certificates found
in ~/.eid/authorized_certificates.

This project is no longer maintained upstream.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/gettext-tools devel/gmake devel/pkgconf

Runtime dependencies

security/libp11 security/libp11

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpam_p11-0.3.1.tgz
NetBSD 8.0earmv7hfpam_p11-0.3.1.tgz
NetBSD 8.0i386pam_p11-0.3.1.tgz
NetBSD 8.0powerpcpam_p11-0.3.1.tgz
NetBSD 8.0powerpcpam_p11-0.3.1.tgz
NetBSD 8.0powerpcpam_p11-0.3.1.tgz
NetBSD 8.0x86_64pam_p11-0.3.1.tgz
NetBSD 9.0aarch64pam_p11-0.3.1.tgz
NetBSD 9.0aarch64pam_p11-0.3.1.tgz
NetBSD 9.0aarch64pam_p11-0.3.1.tgz
NetBSD 9.0alphapam_p11-0.3.1.tgz
NetBSD 9.0alphapam_p11-0.3.1.tgz
NetBSD 9.0alphapam_p11-0.3.1.tgz
NetBSD 9.0earmv6hfpam_p11-0.3.1.tgz
NetBSD 9.0earmv6hfpam_p11-0.3.1.tgz
NetBSD 9.0earmv6hfpam_p11-0.3.1.tgz
NetBSD 9.0earmv7hfpam_p11-0.3.1.tgz
NetBSD 9.0earmv7hfpam_p11-0.3.1.tgz
NetBSD 9.0earmv7hfpam_p11-0.3.1.tgz
NetBSD 9.0earmv7hfpam_p11-0.3.1.tgz
NetBSD 9.0i386pam_p11-0.3.1.tgz
NetBSD 9.0i386pam_p11-0.3.1.tgz
NetBSD 9.0mips64ebpam_p11-0.3.1.tgz
NetBSD 9.0mips64ebpam_p11-0.3.1.tgz
NetBSD 9.0mips64ebpam_p11-0.3.1.tgz
NetBSD 9.0mips64ebpam_p11-0.3.1.tgz
NetBSD 9.0mips64ebpam_p11-0.3.1.tgz
NetBSD 9.0powerpcpam_p11-0.3.1.tgz
NetBSD 9.0powerpcpam_p11-0.3.1.tgz
NetBSD 9.0powerpcpam_p11-0.3.1.tgz
NetBSD 9.0powerpcpam_p11-0.3.1.tgz
NetBSD 9.0sparc64pam_p11-0.3.1.tgz
NetBSD 9.0sparc64pam_p11-0.3.1.tgz
NetBSD 9.0sparc64pam_p11-0.3.1.tgz
NetBSD 9.0sparcpam_p11-0.3.1.tgz
NetBSD 9.0sparcpam_p11-0.3.1.tgz
NetBSD 9.0sparcpam_p11-0.3.1.tgz
NetBSD 9.0x86_64pam_p11-0.3.1.tgz
NetBSD 9.0x86_64pam_p11-0.3.1.tgz
NetBSD 9.0x86_64pam_p11-0.3.1.tgz
NetBSD 9.0x86_64pam_p11-0.3.1.tgz
NetBSD 9.0x86_64pam_p11-0.3.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.