security/clusterssh - The NetBSD Packages Collection

Cluster administration tool

The is the Perl application bundle for ClusterSSH (a.k.a cssh), formally
a GNU tools based project.

ClusterSSH is a tool for making the same change on multiple servers at
the same time.  The 'cssh' command opens an administration console and
an xterm to all specified hosts.  Any text typed into the administration
console is replicated to all windows.  All windows may also be typed into
directly.

This tool is intended for (but not limited to) cluster administration
where the same configuration or commands must be run on each node
within the cluster.  Performing these commands all at once via this
tool ensures all nodes are kept in sync.

Build dependencies

devel/p5-CPAN-Changes devel/p5-File-Which devel/p5-File-Slurp devel/p5-Readonly devel/p5-Test-Differences devel/p5-Test-Pod-Coverage devel/p5-Test-Trap devel/p5-Test-Pod devel/p5-Test-DistManifest x11/xterm devel/p5-Module-Build pkgtools/cwrappers lang/perl5

Runtime dependencies

devel/p5-Exception-Class x11/p5-Tk x11/p5-X11-Protocol devel/p5-Try-Tiny lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 8.0earmv7hfp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 8.0earmv7hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 8.0i386p5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 8.0i386p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 8.0powerpcp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 8.0powerpcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 8.0powerpcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 8.0powerpcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 8.0x86_64p5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 8.0x86_64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0aarch64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0aarch64p5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0aarch64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0alphap5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0alphap5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0alphap5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0earmv6hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0earmv6hfp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0earmv6hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0earmv7hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0earmv7hfp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0earmv7hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0earmv7hfp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0i386p5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0i386p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0i386p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0mips64ebp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0mips64ebp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0mips64ebp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0mips64ebp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0mips64ebp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0powerpcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0powerpcp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0powerpcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0powerpcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0sparc64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0sparc64p5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0sparc64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0sparcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0sparcp5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0sparcp5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0x86_64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0x86_64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0x86_64p5-App-ClusterSSH-4.03.06nb5.tgz
NetBSD 9.0x86_64p5-App-ClusterSSH-4.03.06nb6.tgz
NetBSD 9.0x86_64p5-App-ClusterSSH-4.03.06nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.