devel/p5-Exception-Class - The NetBSD Packages Collection

Perl5 module implementing real exception classes

This module allows you to declare hierarchies of exception classes for
use in your code.  It also provides a simple exception class that it
uses as the default base class for all other exceptions.

You may choose to use another base class for your exceptions.
Regardless, the ability to declare all your exceptions at compile time
is a fairly useful trick and helps push people towards more structured
use of exceptions.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-Data-Inheritable devel/p5-Devel-StackTrace lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0i386p5-Exception-Class-1.44nb3.tgz
NetBSD 8.0i386p5-Exception-Class-1.44nb3.tgz
NetBSD 8.0i386p5-Exception-Class-1.44nb3.tgz
NetBSD 8.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 8.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 8.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 8.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0aarch64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0aarch64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0aarch64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0alphap5-Exception-Class-1.44nb3.tgz
NetBSD 9.0alphap5-Exception-Class-1.44nb3.tgz
NetBSD 9.0alphap5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv6hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv6hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv6hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv6hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0earmv7hfp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0i386p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0i386p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0i386p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0m68kp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0m68kp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0m68kp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0mips64ebp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0mips64ebp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0mips64ebp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0mipselp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0mipselp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0powerpcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sh3elp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sh3elp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sh3elp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sparc64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sparc64p5-Exception-Class-1.44nb2.tgz
NetBSD 9.0sparc64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sparc64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sparcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sparcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0sparcp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0vaxp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0vaxp5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz
NetBSD 9.0x86_64p5-Exception-Class-1.44nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.