print/tex-biblatex - The NetBSD Packages Collection

Sophisticated Bibliographies in LaTeX

The biblatex package is a complete reimplementation of the
bibliographic facilities provided by LaTeX. A custom backend "Biber"
by default is used which processed the BibTeX format data files and
them performs all sorting, label generation (and a great deal
more). Legacy BibTeX is also supported as a backend, albeit with a
reduced feature set. Biblatex does not use the backend to format the
bibliography information as with traditional BibTeX: instead of being
implemented in BibTeX's style files, the formatting of the bibliography
is entirely controlled by TeX macros. Good working knowledge in LaTeX
should be sufficient to design new bibliography and citation styles.
There is no need to learn BibTeX's postfix stack language.
Just like the bibliography styles, all citation commands may
be freely (re)defined. Apart from the features unique to biblatex,
the package also incorporates core features of the following packages:
babelbib,backref, bibtopic, bibunits, chapterbib, cite, citeref, inlinebib,
mlbib, multibib, natbib, splitbib. There are also some conceptual
parallels to the amsrefs package. The biblatex package supports split
bibliographies, multiple bibliographies within one document,and separate
lists of bibliographic shorthands. Bibliographies may be
subdivided into parts (by chapter, by section, etc.) and/or segmented
by topics (by type, by keyword, etc.). With biber as the backend,
features such as customisable sorting, multiple bibliographies with different
sorting, customisable labels, dynamic data modification are available.
The package is fully localized and can interface with the babel package.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

print/tex-etex print/tex-bibtex devel/tex-etoolbox print/tex-kvoptions print/tex-logreq print/tex-pdftexcmds print/tex-url print/p5-biblatex-biber print/kpathsea

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftex-biblatex-3.14.tgz
NetBSD 8.0earmv7hftex-biblatex-3.14.tgz
NetBSD 8.0earmv7hftex-biblatex-3.16.tgz
NetBSD 8.0i386tex-biblatex-3.14.tgz
NetBSD 8.0i386tex-biblatex-3.14.tgz
NetBSD 8.0i386tex-biblatex-3.16.tgz
NetBSD 8.0powerpctex-biblatex-3.14.tgz
NetBSD 8.0powerpctex-biblatex-3.16.tgz
NetBSD 8.0powerpctex-biblatex-3.14.tgz
NetBSD 8.0powerpctex-biblatex-3.16.tgz
NetBSD 8.0x86_64tex-biblatex-3.16.tgz
NetBSD 8.0x86_64tex-biblatex-3.14.tgz
NetBSD 8.0x86_64tex-biblatex-3.14.tgz
NetBSD 9.0aarch64tex-biblatex-3.16.tgz
NetBSD 9.0aarch64tex-biblatex-3.14.tgz
NetBSD 9.0aarch64tex-biblatex-3.14.tgz
NetBSD 9.0earmtex-biblatex-3.14.tgz
NetBSD 9.0earmtex-biblatex-3.16.tgz
NetBSD 9.0earmv6hftex-biblatex-3.16.tgz
NetBSD 9.0earmv6hftex-biblatex-3.14.tgz
NetBSD 9.0earmv6hftex-biblatex-3.14.tgz
NetBSD 9.0earmv6hftex-biblatex-3.14.tgz
NetBSD 9.0earmv7hftex-biblatex-3.16.tgz
NetBSD 9.0earmv7hftex-biblatex-3.14.tgz
NetBSD 9.0earmv7hftex-biblatex-3.14.tgz
NetBSD 9.0earmv7hftex-biblatex-3.14.tgz
NetBSD 9.0earmv7hftex-biblatex-3.16.tgz
NetBSD 9.0i386tex-biblatex-3.14.tgz
NetBSD 9.0i386tex-biblatex-3.14.tgz
NetBSD 9.0i386tex-biblatex-3.16.tgz
NetBSD 9.0powerpctex-biblatex-3.14.tgz
NetBSD 9.0powerpctex-biblatex-3.14.tgz
NetBSD 9.0powerpctex-biblatex-3.16.tgz
NetBSD 9.0sparc64tex-biblatex-3.16.tgz
NetBSD 9.0x86_64tex-biblatex-3.14.tgz
NetBSD 9.0x86_64tex-biblatex-3.14.tgz
NetBSD 9.0x86_64tex-biblatex-3.14.tgz
NetBSD 9.0x86_64tex-biblatex-3.16.tgz
NetBSD 9.0x86_64tex-biblatex-3.14.tgz
NetBSD 9.0x86_64tex-biblatex-3.14.tgz
NetBSD 9.0x86_64tex-biblatex-3.16.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.