print/lilypond - The NetBSD Packages Collection

GNU Music Typesetter

  LilyPond is a music typesetter.  It produces beautiful sheet music using a
high level description file as input.  It excels at typesetting classical
music, but you can also print pop-songs.  With LilyPond we hope to make music
publication software available to anyone on the internet.

  The input to LilyPond is plain text.  So, you can use your favorite text
editor to enter it, you can put it in mail or embed it in an article like
this:

  \relative c'' { \key c \minor; r8 c16 b c8 g as c16 b c8 d | g,4 }

  The output looks very good: the font and the layout algorithms were inspired
by engraved music, so you can expect that same clear and elegant look from
your LilyPond output.  And if you don't like the looks, you can tweak almost
everything.

  The program also has limited MIDI functionality: you can write MIDI files
with lilypond, and we have a simple MIDI to lilypond conversion tool, midi2ly.
Conversion tools for PMX, MUP, ABC, Finale and Musedata are also included.

  LilyPond is free software. It is licensed under GNU General Public License,
so you can use, modify and redistribute the program with almost no
restrictions. LilyPond is part of the GNU Project.

Build dependencies

fonts/tex-metafont graphics/tex-metapost fonts/urw-fonts fonts/intlfonts fonts/font-cronyx-cyrillic fonts/kochi-ttf fonts/fontforge fonts/t1utils textproc/dblatex net/rsync graphics/netpbm graphics/ImageMagick pkgtools/x11-links devel/flex devel/flex x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/bison devel/gmake devel/gtexinfo lang/perl5 devel/pkgconf textproc/texi2html archivers/zip

Runtime dependencies

print/tex-cyrillic fonts/tex-lh fonts/tex-psnfss print/tex-epsf print/tex-graphics graphics/potrace print/ghostscript devel/pango fonts/fontconfig fonts/fontconfig lang/guile lang/python27 textproc/rarian devel/pango fonts/fontconfig lang/guile lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflilypond-2.18.2nb22.tgz
NetBSD 8.0earmv7hflilypond-2.18.2nb23.tgz
NetBSD 8.0i386lilypond-2.18.2nb22.tgz
NetBSD 8.0i386lilypond-2.18.2nb23.tgz
NetBSD 8.0powerpclilypond-2.18.2nb22.tgz
NetBSD 8.0x86_64lilypond-2.18.2nb22.tgz
NetBSD 8.0x86_64lilypond-2.18.2nb23.tgz
NetBSD 9.0aarch64lilypond-2.18.2nb22.tgz
NetBSD 9.0aarch64lilypond-2.18.2nb23.tgz
NetBSD 9.0earmlilypond-2.18.2nb23.tgz
NetBSD 9.0earmlilypond-2.18.2nb23.tgz
NetBSD 9.0earmv6hflilypond-2.18.2nb22.tgz
NetBSD 9.0earmv6hflilypond-2.18.2nb23.tgz
NetBSD 9.0earmv7hflilypond-2.18.2nb22.tgz
NetBSD 9.0earmv7hflilypond-2.18.2nb23.tgz
NetBSD 9.0i386lilypond-2.18.2nb22.tgz
NetBSD 9.0i386lilypond-2.18.2nb23.tgz
NetBSD 9.0mips64eblilypond-2.18.2nb23.tgz
NetBSD 9.0mips64eblilypond-2.18.2nb23.tgz
NetBSD 9.0powerpclilypond-2.18.2nb22.tgz
NetBSD 9.0sh3ellilypond-2.18.2nb23.tgz
NetBSD 9.0sh3ellilypond-2.18.2nb23.tgz
NetBSD 9.0sparc64lilypond-2.18.2nb23.tgz
NetBSD 9.0sparc64lilypond-2.18.2nb22.tgz
NetBSD 9.0sparc64lilypond-2.18.2nb23.tgz
NetBSD 9.0sparclilypond-2.18.2nb23.tgz
NetBSD 9.0sparclilypond-2.18.2nb23.tgz
NetBSD 9.0x86_64lilypond-2.18.2nb23.tgz
NetBSD 9.0x86_64lilypond-2.18.2nb22.tgz
NetBSD 9.0x86_64lilypond-2.18.2nb23.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.