net/cacti - The NetBSD Packages Collection

Web frontend to rrdtool for monitoring systems and services

Cacti is a complete frontend to rrdtool, it stores all of the necessary
information to create graphs and populates them with data in a MySQL
database. The frontend is completely PHP driven. Along with being able
to maintain Graphs, Data Sources, and Round Robin Archives in a
database, cacti handles the data gathering also. There is also SNMP
support for those used to creating traffic graphs with MRTG.

The Plugin Architecture for Cacti was designed to be both simple in nature
and robust enough to allow freedom to do almost anything in Cacti.  The
Plugin Architecture for Cacti is integrated into this package.

Build dependencies

pkgtools/x11-links www/apache24 x11/xorgproto x11/xcb-proto pkgtools/cwrappers www/apache24 devel/glib2-tools lang/perl5

Runtime dependencies

archivers/php-zlib converters/php-mbstring databases/php-pdo_mysql net/php-snmp net/php-sockets devel/php-gmp devel/php-posix databases/php-ldap devel/php-gettext www/ap-php textproc/php-json databases/rrdtool databases/rrdtool

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcacti-1.2.11nb4.tgz
NetBSD 8.0earmv7hfcacti-1.2.11nb4.tgz
NetBSD 8.0i386cacti-1.2.11nb3.tgz
NetBSD 8.0i386cacti-1.2.11nb4.tgz
NetBSD 8.0i386cacti-1.2.11nb4.tgz
NetBSD 8.0x86_64cacti-1.2.11nb4.tgz
NetBSD 8.0x86_64cacti-1.2.11nb3.tgz
NetBSD 8.0x86_64cacti-1.2.11nb4.tgz
NetBSD 9.0aarch64cacti-1.2.11nb4.tgz
NetBSD 9.0aarch64cacti-1.2.11nb3.tgz
NetBSD 9.0aarch64cacti-1.2.11nb4.tgz
NetBSD 9.0earmv6hfcacti-1.2.11nb4.tgz
NetBSD 9.0earmv6hfcacti-1.2.11nb3.tgz
NetBSD 9.0earmv6hfcacti-1.2.11nb4.tgz
NetBSD 9.0earmv6hfcacti-1.2.11nb4.tgz
NetBSD 9.0earmv7hfcacti-1.2.11nb4.tgz
NetBSD 9.0earmv7hfcacti-1.2.11nb3.tgz
NetBSD 9.0earmv7hfcacti-1.2.11nb4.tgz
NetBSD 9.0earmv7hfcacti-1.2.11nb4.tgz
NetBSD 9.0earmv7hfcacti-1.2.11nb4.tgz
NetBSD 9.0i386cacti-1.2.11nb3.tgz
NetBSD 9.0i386cacti-1.2.11nb4.tgz
NetBSD 9.0i386cacti-1.2.11nb4.tgz
NetBSD 9.0mips64ebcacti-1.2.11nb4.tgz
NetBSD 9.0mips64ebcacti-1.2.11nb3.tgz
NetBSD 9.0mips64ebcacti-1.2.11nb4.tgz
NetBSD 9.0sparc64cacti-1.2.11nb4.tgz
NetBSD 9.0sparc64cacti-1.2.11nb1.tgz
NetBSD 9.0sparc64cacti-1.2.11nb3.tgz
NetBSD 9.0sparc64cacti-1.2.11nb4.tgz
NetBSD 9.0x86_64cacti-1.2.11nb4.tgz
NetBSD 9.0x86_64cacti-1.2.11nb4.tgz
NetBSD 9.0x86_64cacti-1.2.11nb4.tgz
NetBSD 9.0x86_64cacti-1.2.11nb4.tgz
NetBSD 9.0x86_64cacti-1.2.11nb3.tgz
NetBSD 9.0x86_64cacti-1.2.11nb4.tgz
NetBSD 9.0x86_64cacti-1.2.11nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.