misc/libcec - The NetBSD Packages Collection

USB CEC Adapter communication Library

libCEC allows you in combination with the right hardware to control your
device with your TV remote control. Utilising your existing HDMI cabling,
it allows developers to interact with other HDMI devices without having to
worry about the communication overhead, handshaking, and the various ways
of sending a message for each vendor.

Build dependencies

pkgtools/x11-links devel/p8-platform x11/xorgproto pkgtools/cwrappers devel/cmake devel/pkgconf

Runtime dependencies

lang/python38 lang/python38 x11/liboldXrandr x11/liboldXrandr x11/liboldXrandr

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibcec-4.0.4nb1.tgz
NetBSD 8.0earmv7hflibcec-4.0.4nb1.tgz
NetBSD 8.0i386libcec-4.0.4.tgz
NetBSD 8.0i386libcec-4.0.4nb1.tgz
NetBSD 8.0i386libcec-4.0.4nb1.tgz
NetBSD 8.0powerpclibcec-4.0.4.tgz
NetBSD 8.0powerpclibcec-4.0.4nb1.tgz
NetBSD 8.0powerpclibcec-4.0.4nb1.tgz
NetBSD 8.0x86_64libcec-4.0.4.tgz
NetBSD 8.0x86_64libcec-4.0.4nb1.tgz
NetBSD 9.0aarch64libcec-4.0.4nb1.tgz
NetBSD 9.0aarch64libcec-4.0.4.tgz
NetBSD 9.0aarch64libcec-4.0.4nb1.tgz
NetBSD 9.0alphalibcec-4.0.4nb1.tgz
NetBSD 9.0alphalibcec-4.0.4.tgz
NetBSD 9.0alphalibcec-4.0.4nb1.tgz
NetBSD 9.0earmv6hflibcec-4.0.4nb1.tgz
NetBSD 9.0earmv6hflibcec-4.0.4.tgz
NetBSD 9.0earmv6hflibcec-4.0.4nb1.tgz
NetBSD 9.0earmv6hflibcec-4.0.4nb1.tgz
NetBSD 9.0earmv7hflibcec-4.0.4nb1.tgz
NetBSD 9.0earmv7hflibcec-4.0.4.tgz
NetBSD 9.0earmv7hflibcec-4.0.4nb1.tgz
NetBSD 9.0earmv7hflibcec-4.0.4nb1.tgz
NetBSD 9.0i386libcec-4.0.4.tgz
NetBSD 9.0i386libcec-4.0.4nb1.tgz
NetBSD 9.0i386libcec-4.0.4nb1.tgz
NetBSD 9.0mips64eblibcec-4.0.4nb1.tgz
NetBSD 9.0mips64eblibcec-4.0.4.tgz
NetBSD 9.0mips64eblibcec-4.0.4nb1.tgz
NetBSD 9.0powerpclibcec-4.0.4nb1.tgz
NetBSD 9.0powerpclibcec-4.0.4.tgz
NetBSD 9.0sparc64libcec-4.0.4nb1.tgz
NetBSD 9.0sparc64libcec-4.0.4.tgz
NetBSD 9.0sparc64libcec-4.0.4nb1.tgz
NetBSD 9.0x86_64libcec-4.0.4.tgz
NetBSD 9.0x86_64libcec-4.0.4nb1.tgz
NetBSD 9.0x86_64libcec-4.0.4nb1.tgz
NetBSD 9.0x86_64libcec-4.0.4.tgz
NetBSD 9.0x86_64libcec-4.0.4nb1.tgz
NetBSD 9.0x86_64libcec-4.0.4nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.