graphics/gd - The NetBSD Packages Collection

Graphics library for the dynamic creation of images

gd is a graphics library. It allows your code to quickly draw images
complete with lines, arcs, text, multiple colors, cut and paste from
other images, and flood fills, and write out the result as a .PNG
file. This is particularly useful in World Wide Web applications,
where .PNG is one of the formats accepted for inline images by most
browsers.

gd is not a paint program. If you are looking for a paint program, you
are looking in the wrong place. If you are not a programmer, you are
looking in the wrong place.

gd does not provide for every possible desirable graphics operation.
It is not necessary or desirable for gd to become a kitchen-sink
graphics package, but incorporates most of the commonly requested
features for an 8-bit 2D package.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

lang/perl5 graphics/tiff fonts/fontconfig fonts/fontconfig graphics/freetype2 graphics/freetype2 graphics/libimagequant graphics/libwebp graphics/png graphics/tiff fonts/fontconfig graphics/libwebp graphics/png

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgd-2.3.0nb2.tgz
NetBSD 8.0earmv7hfgd-2.3.0nb2.tgz
NetBSD 8.0earmv7hfgd-2.3.2.tgz
NetBSD 8.0earmv7hfgd-2.3.2nb1.tgz
NetBSD 8.0i386gd-2.3.0nb2.tgz
NetBSD 8.0i386gd-2.3.0nb2.tgz
NetBSD 8.0i386gd-2.3.2.tgz
NetBSD 8.0i386gd-2.3.2nb1.tgz
NetBSD 8.0powerpcgd-2.3.0nb2.tgz
NetBSD 8.0powerpcgd-2.3.2.tgz
NetBSD 8.0powerpcgd-2.3.0nb2.tgz
NetBSD 8.0powerpcgd-2.3.2.tgz
NetBSD 8.0x86_64gd-2.3.2.tgz
NetBSD 8.0x86_64gd-2.3.0nb2.tgz
NetBSD 8.0x86_64gd-2.3.0nb2.tgz
NetBSD 8.0x86_64gd-2.3.2nb1.tgz
NetBSD 9.0aarch64gd-2.3.2nb1.tgz
NetBSD 9.0aarch64gd-2.3.0nb2.tgz
NetBSD 9.0aarch64gd-2.3.0nb2.tgz
NetBSD 9.0aarch64gd-2.3.2.tgz
NetBSD 9.0alphagd-2.3.2.tgz
NetBSD 9.0alphagd-2.3.2nb1.tgz
NetBSD 9.0earmgd-2.3.2.tgz
NetBSD 9.0earmgd-2.3.2nb1.tgz
NetBSD 9.0earmv6hfgd-2.3.2nb1.tgz
NetBSD 9.0earmv6hfgd-2.3.0nb2.tgz
NetBSD 9.0earmv6hfgd-2.3.0nb2.tgz
NetBSD 9.0earmv6hfgd-2.3.0nb2.tgz
NetBSD 9.0earmv6hfgd-2.3.2.tgz
NetBSD 9.0earmv7hfgd-2.3.2nb1.tgz
NetBSD 9.0earmv7hfgd-2.3.0nb2.tgz
NetBSD 9.0earmv7hfgd-2.3.0nb2.tgz
NetBSD 9.0earmv7hfgd-2.3.0nb2.tgz
NetBSD 9.0earmv7hfgd-2.3.2.tgz
NetBSD 9.0earmv7hfgd-2.3.2.tgz
NetBSD 9.0earmv7hfgd-2.3.2nb1.tgz
NetBSD 9.0i386gd-2.3.0nb2.tgz
NetBSD 9.0i386gd-2.3.0nb2.tgz
NetBSD 9.0i386gd-2.3.2.tgz
NetBSD 9.0i386gd-2.3.2nb1.tgz
NetBSD 9.0m68kgd-2.3.2.tgz
NetBSD 9.0m68kgd-2.3.0nb2.tgz
NetBSD 9.0mips64ebgd-2.3.2.tgz
NetBSD 9.0mips64ebgd-2.3.0nb2.tgz
NetBSD 9.0mips64ebgd-2.3.0nb2.tgz
NetBSD 9.0mips64ebgd-2.3.2nb1.tgz
NetBSD 9.0mipselgd-2.3.0nb2.tgz
NetBSD 9.0mipselgd-2.3.2.tgz
NetBSD 9.0mipselgd-2.3.2nb1.tgz
NetBSD 9.0powerpcgd-2.3.0nb2.tgz
NetBSD 9.0powerpcgd-2.3.0nb2.tgz
NetBSD 9.0powerpcgd-2.3.2.tgz
NetBSD 9.0powerpcgd-2.3.2.tgz
NetBSD 9.0powerpcgd-2.3.2.tgz
NetBSD 9.0sh3elgd-2.3.0nb2.tgz
NetBSD 9.0sh3elgd-2.3.2.tgz
NetBSD 9.0sh3elgd-2.3.2nb1.tgz
NetBSD 9.0sparc64gd-2.3.2.tgz
NetBSD 9.0sparc64gd-2.3.2nb1.tgz
NetBSD 9.0sparcgd-2.3.2.tgz
NetBSD 9.0sparcgd-2.3.0nb2.tgz
NetBSD 9.0sparcgd-2.3.0nb2.tgz
NetBSD 9.0sparcgd-2.3.2nb1.tgz
NetBSD 9.0vaxgd-2.3.2.tgz
NetBSD 9.0vaxgd-2.3.0nb2.tgz
NetBSD 9.0vaxgd-2.3.0nb2.tgz
NetBSD 9.0vaxgd-2.3.2nb1.tgz
NetBSD 9.0x86_64gd-2.3.1.tgz
NetBSD 9.0x86_64gd-2.3.2nb1.tgz
NetBSD 9.0x86_64gd-2.3.2.tgz
NetBSD 9.0x86_64gd-2.3.2nb1.tgz
NetBSD 9.0x86_64gd-2.3.0nb2.tgz
NetBSD 9.0x86_64gd-2.3.0nb2.tgz
NetBSD 9.0x86_64gd-2.3.2.tgz
NetBSD 9.0x86_64gd-2.3.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

tiff
Enable TIFF support.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.