graphics/g2 - The NetBSD Packages Collection

Powerful, easy to use 2D graphics library

g2 is a simple to use graphics library for 2D graphical applications
written in Ansi-C.

This library provides a comprehensive set of functions for
simultaneous generation of graphical output on different types of
devices. Presently, following devices are currently supported by g2:
X11, GIF, PostScript (xfig and Win32 are in development).

One major feature of the g2_library is the concept of virtual
devices. An arbitrary number of physical devices (such as GIF, or X11)
can be grouped to create a so-called virtual device. Commands sent to
such a virtual devices will automatically issued to all attached
physical devices. This allows for example simultaneous output to a GIF
file and a Postscript file. A virtual device in turn can be attached
to another virtual device, allowing to construct trees of devices.
Virtual devices can also be useful when using different
user-coordinate systems. E.g. one X11 window showing an overview of a
graphical output, and a second window showing a zoom of a more
detailed area of the graphic. Drawing in both windows is performed by
one single command to the virtual device.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/libtool-base

Runtime dependencies

graphics/gd lang/perl5 lang/perl5 graphics/gd

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfg2-0.50nb28.tgz
NetBSD 8.0earmv7hfg2-0.50nb27.tgz
NetBSD 8.0earmv7hfg2-0.50nb28.tgz
NetBSD 8.0i386g2-0.50nb27.tgz
NetBSD 8.0i386g2-0.50nb28.tgz
NetBSD 8.0powerpcg2-0.50nb27.tgz
NetBSD 8.0powerpcg2-0.50nb28.tgz
NetBSD 8.0powerpcg2-0.50nb28.tgz
NetBSD 8.0powerpcg2-0.50nb28.tgz
NetBSD 8.0x86_64g2-0.50nb27.tgz
NetBSD 8.0x86_64g2-0.50nb28.tgz
NetBSD 9.0aarch64g2-0.50nb28.tgz
NetBSD 9.0aarch64g2-0.50nb27.tgz
NetBSD 9.0aarch64g2-0.50nb28.tgz
NetBSD 9.0alphag2-0.50nb28.tgz
NetBSD 9.0alphag2-0.50nb27.tgz
NetBSD 9.0alphag2-0.50nb28.tgz
NetBSD 9.0earmv6hfg2-0.50nb28.tgz
NetBSD 9.0earmv6hfg2-0.50nb27.tgz
NetBSD 9.0earmv6hfg2-0.50nb28.tgz
NetBSD 9.0earmv7hfg2-0.50nb28.tgz
NetBSD 9.0earmv7hfg2-0.50nb27.tgz
NetBSD 9.0earmv7hfg2-0.50nb28.tgz
NetBSD 9.0earmv7hfg2-0.50nb28.tgz
NetBSD 9.0i386g2-0.50nb27.tgz
NetBSD 9.0i386g2-0.50nb28.tgz
NetBSD 9.0i386g2-0.50nb28.tgz
NetBSD 9.0mips64ebg2-0.50nb28.tgz
NetBSD 9.0mips64ebg2-0.50nb27.tgz
NetBSD 9.0mips64ebg2-0.50nb27.tgz
NetBSD 9.0mips64ebg2-0.50nb27.tgz
NetBSD 9.0mips64ebg2-0.50nb28.tgz
NetBSD 9.0powerpcg2-0.50nb28.tgz
NetBSD 9.0powerpcg2-0.50nb27.tgz
NetBSD 9.0powerpcg2-0.50nb28.tgz
NetBSD 9.0powerpcg2-0.50nb28.tgz
NetBSD 9.0sparc64g2-0.50nb28.tgz
NetBSD 9.0sparc64g2-0.50nb27.tgz
NetBSD 9.0sparc64g2-0.50nb28.tgz
NetBSD 9.0sparcg2-0.50nb28.tgz
NetBSD 9.0sparcg2-0.50nb27.tgz
NetBSD 9.0sparcg2-0.50nb27.tgz
NetBSD 9.0sparcg2-0.50nb28.tgz
NetBSD 9.0x86_64g2-0.50nb28.tgz
NetBSD 9.0x86_64g2-0.50nb28.tgz
NetBSD 9.0x86_64g2-0.50nb27.tgz
NetBSD 9.0x86_64g2-0.50nb28.tgz
NetBSD 9.0x86_64g2-0.50nb28.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.