devel/p5-MooseX-Traits - The NetBSD Packages Collection

Automatically apply roles at object creation time

Often a developer want to create components that can be added to a class
arbitrarily. This module makes it easy for the end user to use these
components. Instead of requiring the user to create a named class with the
desired roles applied, or applying roles to the instance one-by-one, he can
just pass a traits parameter to the class's new_with_traits constructor.
This role will then apply the roles in one go, cache the resulting class
(for efficiency), and return a new instance. Arguments meant to initialize
the applied roles' attributes can also be passed to the constructor.

Build dependencies

devel/p5-Test-Fatal devel/p5-Test-Requires devel/p5-MooseX-Role-Parameterized devel/p5-Package-DeprecationManager pkgtools/cwrappers

Runtime dependencies

devel/p5-Moose devel/p5-Sub-Exporter devel/p5-namespace-autoclean lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 8.0earmv7hfp5-MooseX-Traits-0.13nb5.tgz
NetBSD 8.0earmv7hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 8.0i386p5-MooseX-Traits-0.13nb5.tgz
NetBSD 8.0i386p5-MooseX-Traits-0.13nb6.tgz
NetBSD 8.0powerpcp5-MooseX-Traits-0.13nb5.tgz
NetBSD 8.0powerpcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 8.0powerpcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 8.0powerpcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 8.0x86_64p5-MooseX-Traits-0.13nb5.tgz
NetBSD 8.0x86_64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0aarch64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0aarch64p5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0aarch64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0alphap5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0alphap5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0alphap5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0earmp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0earmv6hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0earmv7hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0i386p5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0i386p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0i386p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0m68kp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0mips64ebp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0mipselp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0mipselp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0powerpcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0powerpcp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0powerpcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0powerpcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0sh3elp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0sh3elp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sh3elp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sh3elp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sh3elp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0sparc64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0sparc64p5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sparc64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0sparcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0sparcp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sparcp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sparcp5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0sparcp5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Traits-0.13nb5.tgz
NetBSD 9.0x86_64p5-MooseX-Traits-0.13nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Traits-0.13nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.