databases/sqlitebrowser - The NetBSD Packages Collection

Qt5 lightweight GUI editor/viewer for SQLite Databases

SQLite Database Browser is a freeware, public domain, open source
visual tool used to create, design and edit database files compatible
with SQLite. It is meant to be used for users and developers that
want to create databases, edit and search data using a familiar
spreadsheet-like interface, without the need to learn complicated
SQL commands.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake

Runtime dependencies

graphics/hicolor-icon-theme sysutils/desktop-file-utils x11/qt5-qtbase x11/qt5-qscintilla x11/qt5-qttools graphics/hicolor-icon-theme sysutils/desktop-file-utils x11/qt5-qtbase x11/qt5-qscintilla x11/qt5-qttools

Binary packages

OSArchitectureVersion
NetBSD 8.0i386sqlitebrowser-3.12.0nb2.tgz
NetBSD 8.0powerpcsqlitebrowser-3.12.0nb2.tgz
NetBSD 8.0powerpcsqlitebrowser-3.12.1nb2.tgz
NetBSD 8.0powerpcsqlitebrowser-3.12.1nb2.tgz
NetBSD 8.0x86_64sqlitebrowser-3.12.1nb2.tgz
NetBSD 8.0x86_64sqlitebrowser-3.12.0nb2.tgz
NetBSD 8.0x86_64sqlitebrowser-3.12.1.tgz
NetBSD 8.0x86_64sqlitebrowser-3.12.2.tgz
NetBSD 9.0aarch64sqlitebrowser-3.12.2.tgz
NetBSD 9.0aarch64sqlitebrowser-3.12.0nb2.tgz
NetBSD 9.0aarch64sqlitebrowser-3.12.1.tgz
NetBSD 9.0aarch64sqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0i386sqlitebrowser-3.12.0nb2.tgz
NetBSD 9.0i386sqlitebrowser-3.12.1.tgz
NetBSD 9.0i386sqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0powerpcsqlitebrowser-3.12.1.tgz
NetBSD 9.0powerpcsqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0powerpcsqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0sparc64sqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.1nb1.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.2.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.1nb2.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.0nb2.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.1.tgz
NetBSD 9.0x86_64sqlitebrowser-3.12.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.