benchmarks/ramspeed - The NetBSD Packages Collection

RAMspeed, a cache and memory benchmarking tool

RAMspeed, a cache and memory benchmarking tool
(for uniprocessor machines running UNIX-like operating systems).

This command line utility measures effective bandwidth of both cache and memory
subsystems. It has been written entirely in C for portability purposes, though
benchmark routines are also available in several assembly languages for
performance reasons.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hframspeed-2.6.0.tgz
NetBSD 8.0earmv7hframspeed-2.6.0.tgz
NetBSD 8.0earmv7hframspeed-2.6.0.tgz
NetBSD 8.0earmv7hframspeed-2.6.0.tgz
NetBSD 8.0i386ramspeed-2.6.0.tgz
NetBSD 8.0i386ramspeed-2.6.0.tgz
NetBSD 8.0i386ramspeed-2.6.0.tgz
NetBSD 8.0i386ramspeed-2.6.0.tgz
NetBSD 8.0powerpcramspeed-2.6.0.tgz
NetBSD 8.0powerpcramspeed-2.6.0.tgz
NetBSD 8.0powerpcramspeed-2.6.0.tgz
NetBSD 8.0powerpcramspeed-2.6.0.tgz
NetBSD 8.0powerpcramspeed-2.6.0.tgz
NetBSD 8.0x86_64ramspeed-2.6.0.tgz
NetBSD 8.0x86_64ramspeed-2.6.0.tgz
NetBSD 8.0x86_64ramspeed-2.6.0.tgz
NetBSD 8.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0aarch64ramspeed-2.6.0.tgz
NetBSD 9.0aarch64ramspeed-2.6.0.tgz
NetBSD 9.0aarch64ramspeed-2.6.0.tgz
NetBSD 9.0aarch64ramspeed-2.6.0.tgz
NetBSD 9.0alpharamspeed-2.6.0.tgz
NetBSD 9.0alpharamspeed-2.6.0.tgz
NetBSD 9.0earmramspeed-2.6.0.tgz
NetBSD 9.0earmramspeed-2.6.0.tgz
NetBSD 9.0earmv6hframspeed-2.6.0.tgz
NetBSD 9.0earmv6hframspeed-2.6.0.tgz
NetBSD 9.0earmv6hframspeed-2.6.0.tgz
NetBSD 9.0earmv6hframspeed-2.6.0.tgz
NetBSD 9.0earmv6hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0earmv7hframspeed-2.6.0.tgz
NetBSD 9.0i386ramspeed-2.6.0.tgz
NetBSD 9.0i386ramspeed-2.6.0.tgz
NetBSD 9.0i386ramspeed-2.6.0.tgz
NetBSD 9.0i386ramspeed-2.6.0.tgz
NetBSD 9.0mips64ebramspeed-2.6.0.tgz
NetBSD 9.0mips64ebramspeed-2.6.0.tgz
NetBSD 9.0mips64ebramspeed-2.6.0.tgz
NetBSD 9.0mips64ebramspeed-2.6.0.tgz
NetBSD 9.0powerpcramspeed-2.6.0.tgz
NetBSD 9.0powerpcramspeed-2.6.0.tgz
NetBSD 9.0powerpcramspeed-2.6.0.tgz
NetBSD 9.0powerpcramspeed-2.6.0.tgz
NetBSD 9.0powerpcramspeed-2.6.0.tgz
NetBSD 9.0sparc64ramspeed-2.6.0.tgz
NetBSD 9.0sparc64ramspeed-2.6.0.tgz
NetBSD 9.0sparcramspeed-2.6.0.tgz
NetBSD 9.0sparcramspeed-2.6.0.tgz
NetBSD 9.0sparcramspeed-2.6.0.tgz
NetBSD 9.0sparcramspeed-2.6.0.tgz
NetBSD 9.0vaxramspeed-2.6.0.tgz
NetBSD 9.0vaxramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz
NetBSD 9.0x86_64ramspeed-2.6.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.