www/py-httpcore - The NetBSD Packages Collection

Minimal low-level HTTP client

The HTTP Core package provides a minimal low-level HTTP client, which does one
thing only. Sending HTTP requests.

It does not provide any high level model abstractions over the API, does not
handle redirects, multipart uploads, building authentication headers,
transparent HTTP caching, URL parsing, session cookie handling, content or
charset decoding, handling JSON, environment based configuration defaults, or
any of that Jazz.

Some things HTTP Core does do:
* Sending HTTP requests.
* Provides both sync and async interfaces.
* Supports HTTP/1.1 and HTTP/2.
* Async backend support for asyncio and trio.
* Automatic connection pooling.
* HTTP(S) proxy support.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/py-h11 www/py-h2 misc/py-sniffio devel/py-setuptools lang/python38 lang/python38

Available binary packages

aarch64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
aarch64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
aarch64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
aarch64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
aarch64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
aarch64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
aarch64:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
aarch64:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
aarch64:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
aarch64:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
alpha:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
alpha:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
alpha:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
alpha:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
alpha:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
alpha:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
alpha:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
alpha:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
alpha:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
alpha:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
earm:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
earm:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
earm:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv6hf:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv6hf:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py36-httpcore-0.12.2.tgz(NetBSD 8.0)
earmv7hf:py37-httpcore-0.12.2.tgz(NetBSD 8.0)
earmv7hf:py38-httpcore-0.12.2.tgz(NetBSD 8.0)
earmv7hf:py39-httpcore-0.12.2.tgz(NetBSD 8.0)
earmv7hf:py36-httpcore-0.9.1.tgz(NetBSD 8.0)
earmv7hf:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
earmv7hf:py38-httpcore-0.9.1.tgz(NetBSD 8.0)
earmv7hf:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
earmv7hf:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv7hf:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv7hf:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv7hf:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv7hf:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv7hf:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
earmv7hf:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
earmv7hf:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
i386:py36-httpcore-0.9.1.tgz(NetBSD 8.0)
i386:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
i386:py38-httpcore-0.9.1.tgz(NetBSD 8.0)
i386:py36-httpcore-0.9.1.tgz(NetBSD 8.0)
i386:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
i386:py38-httpcore-0.9.1.tgz(NetBSD 8.0)
i386:py36-httpcore-0.12.2.tgz(NetBSD 8.0)
i386:py37-httpcore-0.12.2.tgz(NetBSD 8.0)
i386:py38-httpcore-0.12.2.tgz(NetBSD 8.0)
i386:py39-httpcore-0.12.2.tgz(NetBSD 8.0)
i386:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
i386:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
i386:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
i386:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
i386:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
i386:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
i386:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
i386:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
i386:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
i386:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
mips64eb:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
mips64eb:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
mips64eb:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
mips64eb:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
mips64eb:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
mips64eb:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
mips64eb:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
powerpc:py36-httpcore-0.12.2.tgz(NetBSD 8.0)
powerpc:py37-httpcore-0.12.2.tgz(NetBSD 8.0)
powerpc:py38-httpcore-0.12.2.tgz(NetBSD 8.0)
powerpc:py39-httpcore-0.12.2.tgz(NetBSD 8.0)
powerpc:py36-httpcore-0.9.1.tgz(NetBSD 8.0)
powerpc:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
powerpc:py38-httpcore-0.9.1.tgz(NetBSD 8.0)
powerpc:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
powerpc:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
powerpc:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
powerpc:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
powerpc:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
powerpc:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc64:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc64:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc64:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc64:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
sparc:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
sparc:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.12.0.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.12.0.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.12.0.tgz(NetBSD 9.0)
x86_64:py39-httpcore-0.12.0.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.9.1.tgz(NetBSD 8.0)
x86_64:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
x86_64:py38-httpcore-0.9.1.tgz(NetBSD 8.0)
x86_64:py36-httpcore-0.9.1.tgz(NetBSD 8.0)
x86_64:py37-httpcore-0.9.1.tgz(NetBSD 8.0)
x86_64:py38-httpcore-0.9.1.tgz(NetBSD 8.0)
x86_64:py36-httpcore-0.12.2.tgz(NetBSD 8.0)
x86_64:py37-httpcore-0.12.2.tgz(NetBSD 8.0)
x86_64:py38-httpcore-0.12.2.tgz(NetBSD 8.0)
x86_64:py39-httpcore-0.12.2.tgz(NetBSD 8.0)
x86_64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.9.1.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py39-httpcore-0.12.2.tgz(NetBSD 9.0)
x86_64:py36-httpcore-0.12.3.tgz(NetBSD 9.0)
x86_64:py37-httpcore-0.12.3.tgz(NetBSD 9.0)
x86_64:py38-httpcore-0.12.3.tgz(NetBSD 9.0)
x86_64:py39-httpcore-0.12.3.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]