Daemon Power

The NetBSD Packages Collection: www/py-flask-flatpages

Brief description of the package:
Provides flat static pages to a Flask application

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/SimonSapin/Flask-FlatPages.

Please note that this package has a modified-bsd license.

The package is located in the "www/py-flask-flatpages" directory. The current source version of the package is "py37-flask-flatpages-0.7.2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/py-flask-flatpages :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-pygments>=1.6 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.8 py37-flask>1.0 py37-click>=5.1 py37-itsdangerous>=0.24 py37-jinja2>=2.10.1 py37-babel>=0.8 py37-pytz>=2015.7 py37-markupsafe>=0.23 py37-werkzeug>=0.15 py37-jinja2>=2.10.2 py37-markdown>=2.5 py37-setuptools>=36 py37-yaml>3.12 libyaml>=0.1.1 libyaml>=0.1.4 py37-test-runner-[0-9]* py37-setuptools_scm-[0-9]* py37-toml-[0-9]* py37-test-[0-9]* py37-attrs>=17.4.0 py37-iniconfig-[0-9]* py37-more-itertools>=4.0.0 py37-packaging-[0-9]* py37-pyparsing>=2.0.2 py37-six-[0-9]* py37-pluggy>=0.12 py37-importlib-metadata>=0.12 py37-zipp-[0-9]* py37-setuptools_scm>=1.15.0 py37-py>=1.8.2 .

This package requires the following package(s) to run: py37-pygments>=1.6 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 python37>=3.7.8 py37-flask>1.0 py37-click>=5.1 py37-itsdangerous>=0.24 py37-jinja2>=2.10.1 py37-babel>=0.8 py37-pytz>=2015.7 py37-markupsafe>=0.23 py37-werkzeug>=0.15 py37-jinja2>=2.10.2 py37-markdown>=2.5 py37-setuptools>=36 py37-yaml>3.12 libyaml>=0.1.1 libyaml>=0.1.4 .

This package supports the following build-time options:

pygments
Enable Pygments support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
aarch64:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
aarch64:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
aarch64:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
aarch64:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
aarch64:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
aarch64:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
aarch64:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
aarch64:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
aarch64:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
aarch64:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
alpha:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
alpha:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
alpha:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
alpha:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
alpha:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
alpha:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earm:py27-flask-flatpages-0.6.tgz(NetBSD 7.0)
earm:py33-flask-flatpages-0.6.tgz(NetBSD 7.0)
earm:py34-flask-flatpages-0.6.tgz(NetBSD 7.0)
earm:py35-flask-flatpages-0.6.tgz(NetBSD 7.0)
earm:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earm:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earm:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earm:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv6hf:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv6hf:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv6hf:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv6hf:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv6hf:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv6hf:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv6hf:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv6hf:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py27-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
earmv7hf:py36-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
earmv7hf:py37-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
earmv7hf:py38-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
earmv7hf:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
earmv7hf:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
earmv7hf:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
earmv7hf:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
earmv7hf:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
earmv7hf:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
earmv7hf:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py27-flask-flatpages-0.5.tgz(MirBSD 10)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
i386:py27-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
i386:py36-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
i386:py37-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
i386:py38-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
i386:py27-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
i386:py36-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
i386:py37-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
i386:py38-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
i386:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
i386:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
i386:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
i386:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
i386:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
powerpc:py27-flask-flatpages-0.7.0.tgz(NetBSD 7.1)
powerpc:py34-flask-flatpages-0.7.0.tgz(NetBSD 7.1)
powerpc:py35-flask-flatpages-0.7.0.tgz(NetBSD 7.1)
powerpc:py36-flask-flatpages-0.7.0.tgz(NetBSD 7.1)
powerpc:py37-flask-flatpages-0.7.0.tgz(NetBSD 7.1)
powerpc:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
powerpc:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
powerpc:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
powerpc:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
powerpc:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
powerpc:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
sparc64:py27-flask-flatpages-0.6.tgz(NetBSD 7.1)
sparc64:py34-flask-flatpages-0.6.tgz(NetBSD 7.1)
sparc64:py35-flask-flatpages-0.6.tgz(NetBSD 7.1)
sparc64:py36-flask-flatpages-0.6.tgz(NetBSD 7.1)
sparc64:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
sparc64:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
sparc64:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
sparc64:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
sparc64:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
sparc64:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.0)
x86_64:py27-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
x86_64:py36-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
x86_64:py37-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
x86_64:py38-flask-flatpages-0.7.2.tgz(NetBSD 7.1)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 7.1)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 8.0)
x86_64:py27-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
x86_64:py36-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
x86_64:py37-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
x86_64:py38-flask-flatpages-0.7.2.tgz(NetBSD 8.0)
x86_64:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py27-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py36-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py37-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py38-flask-flatpages-0.7.1.tgz(NetBSD 9.0)
x86_64:py27-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py36-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py37-flask-flatpages-0.7.2.tgz(NetBSD 9.0)
x86_64:py38-flask-flatpages-0.7.2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]