x11/xisxwayland - The NetBSD Packages Collection

Detect if X server is Xwayland

xisxwayland connects to the X server and exits with status code 0
if that server is Xwayland. This tool is intended to be used in
shell scripts and/or to make it easier for users to check whether
they're on a Wayland or X session.

Build dependencies

pkgtools/x11-links x11/xorgproto devel/meson pkgtools/mktools devel/pkgconf pkgtools/cwrappers

Runtime dependencies

x11/liboldXrandr x11/liboldXrandr x11/liboldXrandr

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64xisxwayland-2.tgz
NetBSD 10.0aarch64xisxwayland-2.tgz
NetBSD 10.0earmv6hfxisxwayland-2.tgz
NetBSD 10.0earmv6hfxisxwayland-2.tgz
NetBSD 10.0earmv7hfxisxwayland-2.tgz
NetBSD 10.0earmv7hfxisxwayland-2.tgz
NetBSD 10.0i386xisxwayland-2.tgz
NetBSD 10.0powerpcxisxwayland-2.tgz
NetBSD 10.0powerpcxisxwayland-2.tgz
NetBSD 10.0x86_64xisxwayland-2.tgz
NetBSD 10.0x86_64xisxwayland-2.tgz
NetBSD 8.0i386xisxwayland-2.tgz
NetBSD 8.0powerpcxisxwayland-2.tgz
NetBSD 8.0powerpcxisxwayland-2.tgz
NetBSD 8.0x86_64xisxwayland-2.tgz
NetBSD 9.0aarch64xisxwayland-2.tgz
NetBSD 9.0aarch64xisxwayland-2.tgz
NetBSD 9.0alphaxisxwayland-2.tgz
NetBSD 9.0alphaxisxwayland-2.tgz
NetBSD 9.0earmv6hfxisxwayland-2.tgz
NetBSD 9.0earmv6hfxisxwayland-2.tgz
NetBSD 9.0earmv7hfxisxwayland-2.tgz
NetBSD 9.0earmv7hfxisxwayland-2.tgz
NetBSD 9.0i386xisxwayland-2.tgz
NetBSD 9.0m68kxisxwayland-2.tgz
NetBSD 9.0m68kxisxwayland-2.tgz
NetBSD 9.0powerpcxisxwayland-2.tgz
NetBSD 9.0powerpcxisxwayland-2.tgz
NetBSD 9.0sparc64xisxwayland-2.tgz
NetBSD 9.0sparc64xisxwayland-2.tgz
NetBSD 9.0x86_64xisxwayland-2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.