x11/py-gtk2 - The NetBSD Packages Collection

Python bindings for GTK+2

This archive contains modules that allow you to use gtk in Python
programs.  At present, it is a fairly complete set of bindings.
Despite the low version number, this piece of software is quite
useful, and is usable to write moderately complex programs.  (See the
examples directory for some examples of the simpler programs you could
write).

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto devel/py-gobject-shared pkgtools/cwrappers devel/py-gobject-shared devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

lang/python27 devel/libglade x11/gtk2 x11/gtk2 graphics/py-cairo118 devel/py-gobject devel/py-gobject lang/python27 devel/libglade x11/gtk2 graphics/py-cairo118 devel/py-gobject

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 8.0earmv7hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 8.0i386py27-gtk2-2.24.0nb34.tgz
NetBSD 8.0i386py27-gtk2-2.24.0nb36.tgz
NetBSD 8.0i386py27-gtk2-2.24.0nb36.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb29.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb32.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb33.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb34.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb29.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb32.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb33.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb34.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb36.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb29.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb32.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb33.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb34.tgz
NetBSD 8.0powerpcpy27-gtk2-2.24.0nb36.tgz
NetBSD 8.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 8.0x86_64py27-gtk2-2.24.0nb34.tgz
NetBSD 8.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0aarch64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0aarch64py27-gtk2-2.24.0nb34.tgz
NetBSD 9.0aarch64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0alphapy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0alphapy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0alphapy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0earmpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmv6hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmv6hfpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0earmv6hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmv6hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmv7hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmv7hfpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0earmv7hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0earmv7hfpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0i386py27-gtk2-2.24.0nb34.tgz
NetBSD 9.0i386py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0i386py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0m68kpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0mips64ebpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0mips64ebpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0mips64ebpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0mipselpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb29.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb32.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb33.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb29.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb32.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb33.tgz
NetBSD 9.0powerpcpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0sh3elpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0sh3elpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0sparc64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0sparc64py27-gtk2-2.24.0nb33.tgz
NetBSD 9.0sparc64py27-gtk2-2.24.0nb34.tgz
NetBSD 9.0sparc64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0sparcpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0sparcpy27-gtk2-2.24.0nb34.tgz
NetBSD 9.0sparcpy27-gtk2-2.24.0nb36.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb34.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb36.tgz
NetBSD 9.0x86_64py27-gtk2-2.24.0nb36.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

py-numpy
Enable support for NumPy.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.