x11/mlterm - The NetBSD Packages Collection

Multilingual terminal emulator

mlterm is a Multi Lingual TERMinal emulator for X and
framebuffer console.  It supports many character sets,
many encodings, and many other decorative functions.
Since mlterm retains character tables in memory to
convert characters between UCS and other encodings,
it consumes a lot of memory while running, so it's
recommended that you open multiple ptys in one process.

Build dependencies

pkgtools/x11-links x11/xcb-proto x11/xorgproto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/pkgconf

Runtime dependencies

graphics/cairo converters/fribidi graphics/gdk-pixbuf2 devel/m17n-lib fonts/Xft2 fonts/Xft2 fonts/harfbuzz x11/gtk2 graphics/cairo graphics/gdk-pixbuf2 devel/m17n-lib fonts/Xft2 fonts/harfbuzz x11/gtk2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmlterm-3.9.1nb1.tgz
NetBSD 8.0earmv7hfmlterm-3.9.1.tgz
NetBSD 8.0earmv7hfmlterm-3.9.1nb1.tgz
NetBSD 8.0i386mlterm-3.9.1.tgz
NetBSD 8.0i386mlterm-3.9.1nb1.tgz
NetBSD 8.0powerpcmlterm-3.9.1.tgz
NetBSD 8.0powerpcmlterm-3.9.1nb1.tgz
NetBSD 8.0powerpcmlterm-3.9.1nb1.tgz
NetBSD 8.0powerpcmlterm-3.9.1nb1.tgz
NetBSD 8.0x86_64mlterm-3.9.1.tgz
NetBSD 8.0x86_64mlterm-3.9.1nb1.tgz
NetBSD 9.0aarch64mlterm-3.9.1nb1.tgz
NetBSD 9.0aarch64mlterm-3.9.1.tgz
NetBSD 9.0aarch64mlterm-3.9.1nb1.tgz
NetBSD 9.0alphamlterm-3.9.1nb1.tgz
NetBSD 9.0alphamlterm-3.9.1.tgz
NetBSD 9.0alphamlterm-3.9.1nb1.tgz
NetBSD 9.0earmv6hfmlterm-3.9.1nb1.tgz
NetBSD 9.0earmv6hfmlterm-3.9.1.tgz
NetBSD 9.0earmv6hfmlterm-3.9.1nb1.tgz
NetBSD 9.0earmv7hfmlterm-3.9.1nb1.tgz
NetBSD 9.0earmv7hfmlterm-3.9.1.tgz
NetBSD 9.0earmv7hfmlterm-3.9.1nb1.tgz
NetBSD 9.0earmv7hfmlterm-3.9.1nb1.tgz
NetBSD 9.0i386mlterm-3.9.1.tgz
NetBSD 9.0i386mlterm-3.9.1nb1.tgz
NetBSD 9.0i386mlterm-3.9.1nb1.tgz
NetBSD 9.0mips64ebmlterm-3.9.1nb1.tgz
NetBSD 9.0mips64ebmlterm-3.9.0nb3.tgz
NetBSD 9.0mips64ebmlterm-3.9.1.tgz
NetBSD 9.0mips64ebmlterm-3.9.1.tgz
NetBSD 9.0mips64ebmlterm-3.9.1nb1.tgz
NetBSD 9.0powerpcmlterm-3.9.1nb1.tgz
NetBSD 9.0powerpcmlterm-3.9.1.tgz
NetBSD 9.0powerpcmlterm-3.9.1nb1.tgz
NetBSD 9.0powerpcmlterm-3.9.1nb1.tgz
NetBSD 9.0sparc64mlterm-3.9.1nb1.tgz
NetBSD 9.0sparc64mlterm-3.9.1.tgz
NetBSD 9.0sparc64mlterm-3.9.1nb1.tgz
NetBSD 9.0sparcmlterm-3.9.1nb1.tgz
NetBSD 9.0sparcmlterm-3.9.0nb3.tgz
NetBSD 9.0sparcmlterm-3.9.1.tgz
NetBSD 9.0sparcmlterm-3.9.1.tgz
NetBSD 9.0sparcmlterm-3.9.1nb1.tgz
NetBSD 9.0x86_64mlterm-3.9.1nb1.tgz
NetBSD 9.0x86_64mlterm-3.9.1nb1.tgz
NetBSD 9.0x86_64mlterm-3.9.1.tgz
NetBSD 9.0x86_64mlterm-3.9.1nb1.tgz
NetBSD 9.0x86_64mlterm-3.9.1nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

cairo
Enable cairo support.
canna
Use Canna as Japanese conversion program.
fcitx
Enable Fcitx inputmethod support
fribidi
Enable BIDI support using fribidi.
gdk_pixbuf2
ibus
Enable Intelligent Input Bus support.
libind
Add Indian script support using libind.
m17nlib
Enable the m17n library support.
mlterm-fb
Enable framebuffer support.
otl
scim
Enable Smart Common Input Method support.
skk
Use SKK for Kana-to-Kanji conversion.
uim
Enable UIM support.
wnn4
Use wnn for Kana-to-Kanji conversion.
xft2
Enable Xft support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.