x11/fltk - The NetBSD Packages Collection

Fast Light Tool Kit for graphical user interfaces (old 1.1 branch)

FLTK (pronounced "fulltick") is a LGPL'd C++ graphical user interface
toolkit for X (UNIX), OpenGL, and Win32.  FLTK was designed to be small and
modular enough to be statically linked, but also works fine as a shared
library.  FLTK also includes FLUID, an interactive user interface builder
program.

This is version 1.1.  From the FLTK website:

  FLTK 1.1.x is the former stable development branch. It is no longer
  being maintained, and any bug fixes will be applied against FLTK
  1.3.x.

  We recommend using the active FLTK 1.3.0 branch instead.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

graphics/MesaLib graphics/glu graphics/glu graphics/jpeg graphics/png graphics/MesaLib graphics/glu graphics/jpeg graphics/png

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 8.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 8.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 8.0i386fltk-1.1.10nb7.tgz
NetBSD 8.0i386fltk-1.1.10nb7.tgz
NetBSD 8.0powerpcfltk-1.1.10nb7.tgz
NetBSD 8.0powerpcfltk-1.1.10nb7.tgz
NetBSD 8.0powerpcfltk-1.1.10nb7.tgz
NetBSD 8.0x86_64fltk-1.1.10nb7.tgz
NetBSD 8.0x86_64fltk-1.1.10nb7.tgz
NetBSD 9.0aarch64fltk-1.1.10nb7.tgz
NetBSD 9.0aarch64fltk-1.1.10nb7.tgz
NetBSD 9.0aarch64fltk-1.1.10nb7.tgz
NetBSD 9.0alphafltk-1.1.10nb7.tgz
NetBSD 9.0alphafltk-1.1.10nb7.tgz
NetBSD 9.0alphafltk-1.1.10nb7.tgz
NetBSD 9.0earmfltk-1.1.10nb7.tgz
NetBSD 9.0earmfltk-1.1.10nb7.tgz
NetBSD 9.0earmfltk-1.1.10nb7.tgz
NetBSD 9.0earmv6hffltk-1.1.10nb7.tgz
NetBSD 9.0earmv6hffltk-1.1.10nb7.tgz
NetBSD 9.0earmv6hffltk-1.1.10nb7.tgz
NetBSD 9.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 9.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 9.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 9.0earmv7hffltk-1.1.10nb7.tgz
NetBSD 9.0i386fltk-1.1.10nb7.tgz
NetBSD 9.0i386fltk-1.1.10nb7.tgz
NetBSD 9.0i386fltk-1.1.10nb7.tgz
NetBSD 9.0mips64ebfltk-1.1.10nb7.tgz
NetBSD 9.0mips64ebfltk-1.1.10nb7.tgz
NetBSD 9.0mips64ebfltk-1.1.10nb7.tgz
NetBSD 9.0mips64ebfltk-1.1.10nb7.tgz
NetBSD 9.0mips64ebfltk-1.1.10nb7.tgz
NetBSD 9.0powerpcfltk-1.1.10nb7.tgz
NetBSD 9.0powerpcfltk-1.1.10nb7.tgz
NetBSD 9.0powerpcfltk-1.1.10nb7.tgz
NetBSD 9.0powerpcfltk-1.1.10nb7.tgz
NetBSD 9.0sh3elfltk-1.1.10nb7.tgz
NetBSD 9.0sh3elfltk-1.1.10nb7.tgz
NetBSD 9.0sh3elfltk-1.1.10nb7.tgz
NetBSD 9.0sparc64fltk-1.1.10nb7.tgz
NetBSD 9.0sparc64fltk-1.1.10nb7.tgz
NetBSD 9.0sparc64fltk-1.1.10nb7.tgz
NetBSD 9.0sparcfltk-1.1.10nb7.tgz
NetBSD 9.0sparcfltk-1.1.10nb7.tgz
NetBSD 9.0sparcfltk-1.1.10nb7.tgz
NetBSD 9.0sparcfltk-1.1.10nb7.tgz
NetBSD 9.0sparcfltk-1.1.10nb7.tgz
NetBSD 9.0vaxfltk-1.1.10nb7.tgz
NetBSD 9.0vaxfltk-1.1.10nb7.tgz
NetBSD 9.0vaxfltk-1.1.10nb7.tgz
NetBSD 9.0x86_64fltk-1.1.10nb7.tgz
NetBSD 9.0x86_64fltk-1.1.10nb7.tgz
NetBSD 9.0x86_64fltk-1.1.10nb7.tgz
NetBSD 9.0x86_64fltk-1.1.10nb7.tgz
NetBSD 9.0x86_64fltk-1.1.10nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.