www/ruby-faraday-retry1 - The NetBSD Packages Collection

Catches exceptions and retries each request a limited times

Faraday Retry

The Retry middleware automatically retries requests that fail due to
intermittent client or server errors (such as network hiccups).

By default, it retries 2 times and handles only timeout exceptions.

It can be configured with an arbitrary number of retries, a list of
exceptions to handle, a retry interval, a percentage of randomness to add to
the retry interval, and a backoff factor.

The middleware can also handle the Retry-After header automatically when
configured with the right status codes (see below for an example).

This is version 1.x package.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

lang/ruby31-base

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ruby27-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ruby30-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ruby31-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ruby32-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ebruby27-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ebruby30-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ebruby31-faraday-retry1-1.0.3.tgz
NetBSD 10.0aarch64ebruby32-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv6hfruby27-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv6hfruby30-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv6hfruby31-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv6hfruby32-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv7hfruby27-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv7hfruby30-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv7hfruby31-faraday-retry1-1.0.3.tgz
NetBSD 10.0earmv7hfruby32-faraday-retry1-1.0.3.tgz
NetBSD 8.0i386ruby27-faraday-retry1-1.0.3.tgz
NetBSD 8.0i386ruby30-faraday-retry1-1.0.3.tgz
NetBSD 8.0i386ruby31-faraday-retry1-1.0.3.tgz
NetBSD 8.0i386ruby32-faraday-retry1-1.0.3.tgz
NetBSD 8.0powerpcruby27-faraday-retry1-1.0.3.tgz
NetBSD 8.0powerpcruby30-faraday-retry1-1.0.3.tgz
NetBSD 8.0powerpcruby31-faraday-retry1-1.0.3.tgz
NetBSD 8.0powerpcruby27-faraday-retry1-1.0.3.tgz
NetBSD 8.0powerpcruby30-faraday-retry1-1.0.3.tgz
NetBSD 8.0powerpcruby31-faraday-retry1-1.0.3.tgz
NetBSD 8.0x86_64ruby27-faraday-retry1-1.0.3.tgz
NetBSD 8.0x86_64ruby30-faraday-retry1-1.0.3.tgz
NetBSD 8.0x86_64ruby31-faraday-retry1-1.0.3.tgz
NetBSD 8.0x86_64ruby32-faraday-retry1-1.0.3.tgz
NetBSD 9.0aarch64ruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0aarch64ruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0aarch64ruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0aarch64ruby32-faraday-retry1-1.0.3.tgz
NetBSD 9.0alpharuby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv6hfruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv6hfruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv6hfruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv6hfruby32-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv7hfruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv7hfruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv7hfruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0earmv7hfruby32-faraday-retry1-1.0.3.tgz
NetBSD 9.0i386ruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0i386ruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0i386ruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0i386ruby32-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparc64ruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparc64ruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparc64ruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparc64ruby32-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparcruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparcruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0sparcruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0vaxruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0x86_64ruby27-faraday-retry1-1.0.3.tgz
NetBSD 9.0x86_64ruby30-faraday-retry1-1.0.3.tgz
NetBSD 9.0x86_64ruby31-faraday-retry1-1.0.3.tgz
NetBSD 9.0x86_64ruby32-faraday-retry1-1.0.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.