www/py-scrapy - The NetBSD Packages Collection

High-level Web Crawling and Web Scraping framework

Scrapy is a fast high-level web crawling and web scraping framework, used to
crawl websites and extract structured data from their pages. It can be used for
a wide range of purposes, from data mining to monitoring and automated testing.

Build dependencies

devel/py-wheel devel/py-build misc/py-installer pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

textproc/py-cssselect textproc/py-defusedxml textproc/py-itemadapter textproc/py-itemloaders textproc/py-lxml devel/py-packaging www/py-parsel www/py-protego devel/py-pydispatcher devel/py-queuelib security/py-service_identity devel/py-setuptools net/py-tldextract net/py-twisted www/py-w3lib devel/py-zope.interface security/py-cryptography security/py-OpenSSL lang/python311 lang/python311

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64py310-scrapy-2.11.1.tgz
NetBSD 10.0aarch64py311-scrapy-2.11.1.tgz
NetBSD 10.0aarch64py312-scrapy-2.11.1.tgz
NetBSD 10.0aarch64py38-scrapy-2.11.1.tgz
NetBSD 10.0aarch64py39-scrapy-2.11.1.tgz
NetBSD 10.0aarch64py310-scrapy-2.11.0.tgz
NetBSD 10.0aarch64py311-scrapy-2.11.0.tgz
NetBSD 10.0aarch64py312-scrapy-2.11.0.tgz
NetBSD 10.0aarch64py38-scrapy-2.11.0.tgz
NetBSD 10.0aarch64py39-scrapy-2.11.0.tgz
NetBSD 10.0earmv7hfpy310-scrapy-2.11.1.tgz
NetBSD 10.0earmv7hfpy311-scrapy-2.11.1.tgz
NetBSD 10.0earmv7hfpy312-scrapy-2.11.1.tgz
NetBSD 10.0earmv7hfpy38-scrapy-2.11.1.tgz
NetBSD 10.0earmv7hfpy39-scrapy-2.11.1.tgz
NetBSD 10.0earmv7hfpy310-scrapy-2.11.0.tgz
NetBSD 10.0earmv7hfpy311-scrapy-2.11.0.tgz
NetBSD 10.0earmv7hfpy312-scrapy-2.11.0.tgz
NetBSD 10.0earmv7hfpy38-scrapy-2.11.0.tgz
NetBSD 10.0earmv7hfpy39-scrapy-2.11.0.tgz
NetBSD 10.0i386py310-scrapy-2.11.1.tgz
NetBSD 10.0i386py311-scrapy-2.11.1.tgz
NetBSD 10.0i386py312-scrapy-2.11.1.tgz
NetBSD 10.0i386py38-scrapy-2.11.1.tgz
NetBSD 10.0i386py39-scrapy-2.11.1.tgz
NetBSD 10.0i386py310-scrapy-2.11.0.tgz
NetBSD 10.0i386py311-scrapy-2.11.0.tgz
NetBSD 10.0i386py312-scrapy-2.11.0.tgz
NetBSD 10.0i386py38-scrapy-2.11.0.tgz
NetBSD 10.0i386py39-scrapy-2.11.0.tgz
NetBSD 10.0powerpcpy310-scrapy-2.9.0.tgz
NetBSD 10.0powerpcpy311-scrapy-2.9.0.tgz
NetBSD 10.0powerpcpy38-scrapy-2.9.0.tgz
NetBSD 10.0powerpcpy39-scrapy-2.9.0.tgz
NetBSD 10.0powerpcpy38-scrapy-2.11.0.tgz
NetBSD 10.0x86_64py310-scrapy-2.11.1.tgz
NetBSD 10.0x86_64py311-scrapy-2.11.1.tgz
NetBSD 10.0x86_64py312-scrapy-2.11.1.tgz
NetBSD 10.0x86_64py38-scrapy-2.11.1.tgz
NetBSD 10.0x86_64py39-scrapy-2.11.1.tgz
NetBSD 10.0x86_64py310-scrapy-2.11.0.tgz
NetBSD 10.0x86_64py311-scrapy-2.11.0.tgz
NetBSD 10.0x86_64py312-scrapy-2.11.0.tgz
NetBSD 10.0x86_64py38-scrapy-2.11.0.tgz
NetBSD 10.0x86_64py39-scrapy-2.11.0.tgz
NetBSD 9.0aarch64py310-scrapy-2.11.0.tgz
NetBSD 9.0aarch64py311-scrapy-2.11.0.tgz
NetBSD 9.0aarch64py312-scrapy-2.11.0.tgz
NetBSD 9.0aarch64py38-scrapy-2.11.0.tgz
NetBSD 9.0aarch64py39-scrapy-2.11.0.tgz
NetBSD 9.0earmv7hfpy310-scrapy-2.11.1.tgz
NetBSD 9.0earmv7hfpy311-scrapy-2.11.1.tgz
NetBSD 9.0earmv7hfpy38-scrapy-2.11.1.tgz
NetBSD 9.0earmv7hfpy39-scrapy-2.11.1.tgz
NetBSD 9.0earmv7hfpy310-scrapy-2.11.0.tgz
NetBSD 9.0earmv7hfpy311-scrapy-2.11.0.tgz
NetBSD 9.0earmv7hfpy38-scrapy-2.11.0.tgz
NetBSD 9.0earmv7hfpy39-scrapy-2.11.0.tgz
NetBSD 9.0i386py310-scrapy-2.11.1.tgz
NetBSD 9.0i386py311-scrapy-2.11.1.tgz
NetBSD 9.0i386py312-scrapy-2.11.1.tgz
NetBSD 9.0i386py38-scrapy-2.11.1.tgz
NetBSD 9.0i386py39-scrapy-2.11.1.tgz
NetBSD 9.0i386py310-scrapy-2.11.0.tgz
NetBSD 9.0i386py311-scrapy-2.11.0.tgz
NetBSD 9.0i386py38-scrapy-2.11.0.tgz
NetBSD 9.0i386py39-scrapy-2.11.0.tgz
NetBSD 9.0sparc64py310-scrapy-2.4.1nb2.tgz
NetBSD 9.0sparc64py311-scrapy-2.4.1nb2.tgz
NetBSD 9.0sparc64py38-scrapy-2.4.1nb2.tgz
NetBSD 9.0sparc64py39-scrapy-2.4.1nb2.tgz
NetBSD 9.0x86_64py310-scrapy-2.11.1.tgz
NetBSD 9.0x86_64py311-scrapy-2.11.1.tgz
NetBSD 9.0x86_64py312-scrapy-2.11.1.tgz
NetBSD 9.0x86_64py38-scrapy-2.11.1.tgz
NetBSD 9.0x86_64py39-scrapy-2.11.1.tgz
NetBSD 9.0x86_64py310-scrapy-2.11.0.tgz
NetBSD 9.0x86_64py311-scrapy-2.11.0.tgz
NetBSD 9.0x86_64py312-scrapy-2.11.0.tgz
NetBSD 9.0x86_64py38-scrapy-2.11.0.tgz
NetBSD 9.0x86_64py39-scrapy-2.11.0.tgz
NetBSD 9.3x86_64py310-scrapy-2.11.1.tgz
NetBSD 9.3x86_64py311-scrapy-2.11.1.tgz
NetBSD 9.3x86_64py312-scrapy-2.11.1.tgz
NetBSD 9.3x86_64py38-scrapy-2.11.1.tgz
NetBSD 9.3x86_64py39-scrapy-2.11.1.tgz
NetBSD 9.3x86_64py310-scrapy-2.11.2.tgz
NetBSD 9.3x86_64py311-scrapy-2.11.2.tgz
NetBSD 9.3x86_64py312-scrapy-2.11.2.tgz
NetBSD 9.3x86_64py38-scrapy-2.11.2.tgz
NetBSD 9.3x86_64py39-scrapy-2.11.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.