www/p5-HTML-Gumbo - The NetBSD Packages Collection

HTML5 parser based on gumbo C library

Gumbo is an implementation of the HTML5 parsing algorithm implemented as
a pure C99 library with no outside dependencies.

Goals and features of the C library:
* Fully conformant with the HTML5 spec.
* Robust and resilient to bad input.
* Simple API that can be easily wrapped by other languages. (This is one
  of such wrappers.)
* Support for source locations and pointers back to the original text.
  (Not exposed by this implementation at the moment.)
* Relatively lightweight, with no outside dependencies.
* Passes all html5lib-0.95 tests.
* Tested on over 2.5 billion pages from Google's index.

Build dependencies

devel/p5-PkgConfig devel/p5-Module-Build pkgtools/mktools devel/pkgconf pkgtools/cwrappers

Runtime dependencies

www/p5-Alien-LibGumbo lang/perl5 lang/perl5 www/gumbo-parser www/gumbo-parser

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0aarch64p5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0aarch64ebp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0alphap5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0alphap5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0earmv6hfp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0earmv6hfp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0earmv7hfp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0earmv7hfp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0i386p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0i386p5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0m68kp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0powerpcp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0powerpcp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0sh3elp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0sparc64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0sparcp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0vaxp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 10.0x86_64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 10.0x86_64p5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0aarch64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0aarch64p5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0alphap5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0alphap5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0earmp5-HTML-Gumbo-0.18nb1.tgz
NetBSD 9.0earmv6hfp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0earmv6hfp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0earmv7hfp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0earmv7hfp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0i386p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0i386p5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0mips64ebp5-HTML-Gumbo-0.18nb1.tgz
NetBSD 9.0powerpcp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0powerpcp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0powerpcp5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0sh3elp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0sparc64p5-HTML-Gumbo-0.18nb1.tgz
NetBSD 9.0vaxp5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.0x86_64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.0x86_64p5-HTML-Gumbo-0.18nb2.tgz
NetBSD 9.3x86_64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.3x86_64p5-HTML-Gumbo-0.18nb3.tgz
NetBSD 9.3x86_64p5-HTML-Gumbo-0.18nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.