textproc/p5-YAML-Tiny - The NetBSD Packages Collection

Read/Write YAML files with as little code as possible

YAML::Tiny is a perl class for reading and writing YAML-style files,
written with as little code as possible, reducing load time and
memory overhead.

Most of the time it is accepted that Perl applications use a lot
of memory and modules. The ::Tiny family of modules is specifically
intended to provide an ultralight and zero-dependency alternative
to many more-thorough standard modules.

This module is primarily for reading human-written files (like
simple config files) and generating very simple human-readable
files. Note that I said human-readable and not geek-readable. The
sort of files that your average manager or secretary should be able
to look at and make sense of.

YAML::Tiny does not generate comments, it won't necesarily preserve
the order of your hashes, and it will normalise if reading in and
writing out again.

It only supports a very basic subset of the full YAML specification.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 8.0earmv7hfp5-YAML-Tiny-1.73nb3.tgz
NetBSD 8.0earmv7hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 8.0i386p5-YAML-Tiny-1.73nb3.tgz
NetBSD 8.0i386p5-YAML-Tiny-1.73nb4.tgz
NetBSD 8.0powerpcp5-YAML-Tiny-1.73nb3.tgz
NetBSD 8.0powerpcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 8.0powerpcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 8.0powerpcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 8.0x86_64p5-YAML-Tiny-1.73nb3.tgz
NetBSD 8.0x86_64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0aarch64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0aarch64p5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0aarch64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0alphap5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0alphap5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0alphap5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0earmp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmv6hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmv6hfp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0earmv6hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmv7hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmv7hfp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0earmv7hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0earmv7hfp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0i386p5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0i386p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0m68kp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0m68kp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0m68kp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0m68kp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0mips64ebp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0mips64ebp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0mips64ebp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0mips64ebp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0mips64ebp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0mipselp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0mipselp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0mipselp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0mipselp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0powerpcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0powerpcp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0powerpcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0powerpcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0sh3elp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0sh3elp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sh3elp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sh3elp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sh3elp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0sparc64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0sparc64p5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sparc64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0sparcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0sparcp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sparcp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sparcp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0sparcp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0vaxp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0vaxp5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0vaxp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0vaxp5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0x86_64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0x86_64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0x86_64p5-YAML-Tiny-1.73nb3.tgz
NetBSD 9.0x86_64p5-YAML-Tiny-1.73nb4.tgz
NetBSD 9.0x86_64p5-YAML-Tiny-1.73nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.