textproc/p5-XML-TokeParser - The NetBSD Packages Collection

Simplified interface to XML::Parser

XML::TokeParser provides a procedural ("pull mode") interface to XML::Parser
in much the same way that Gisle Aas' HTML::TokeParser provides a procedural
interface to HTML::Parser. XML::TokeParser splits its XML input up into
"tokens," each corresponding to an XML::Parser event.

A token is a bless'd reference to an array whose first element is an
event-type string and whose last element is the literal text of the
XML input that generated the event, with intermediate elements varying
according to the event type.

Each token is an object of type XML::TokeParser::Token. Read
"XML::TokeParser::Token" to learn what methods are available for
inspecting the token, and retrieving data from it.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/p5-XML-Parser lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 8.0earmv7hfp5-XML-TokeParser-0.05nb5.tgz
NetBSD 8.0earmv7hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 8.0i386p5-XML-TokeParser-0.05nb5.tgz
NetBSD 8.0i386p5-XML-TokeParser-0.05nb6.tgz
NetBSD 8.0powerpcp5-XML-TokeParser-0.05nb5.tgz
NetBSD 8.0powerpcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 8.0powerpcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 8.0powerpcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 8.0x86_64p5-XML-TokeParser-0.05nb5.tgz
NetBSD 8.0x86_64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0aarch64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0aarch64p5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0aarch64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0alphap5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0alphap5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0alphap5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0earmp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmv6hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmv6hfp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0earmv6hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmv7hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmv7hfp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0earmv7hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0earmv7hfp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0i386p5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0i386p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0i386p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0mips64ebp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0mips64ebp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0mips64ebp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0mips64ebp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0mips64ebp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0mipselp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0mipselp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0powerpcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0powerpcp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0powerpcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0powerpcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0sh3elp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0sh3elp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0sh3elp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0sh3elp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0sparc64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0sparc64p5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0sparc64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0sparcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0sparcp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0sparcp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0sparcp5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0sparcp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0vaxp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0vaxp5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0x86_64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0x86_64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0x86_64p5-XML-TokeParser-0.05nb5.tgz
NetBSD 9.0x86_64p5-XML-TokeParser-0.05nb6.tgz
NetBSD 9.0x86_64p5-XML-TokeParser-0.05nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.