textproc/p5-XML-Parser-Lite - The NetBSD Packages Collection

Lightweight regexp-based XML parser

This Perl module implements an XML parser with a interface similar to
XML::Parser. Though not all callbacks are supported, you should be able
to use it in the same way you use XML::Parser. Due to using experimental
regexp features it'll work only on Perl 5.6 and above and may behave
differently on different platforms.

Note that you cannot use regular expressions or split in callbacks. This
is due to a limitation of perl's regular expression implementation
(which is not re-entrant).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0i386p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0i386p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0i386p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0powerpcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0powerpcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0powerpcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 8.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0aarch64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0aarch64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0aarch64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0alphap5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0alphap5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0alphap5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv6hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv6hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv6hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv6hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0earmv7hfp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0i386p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0i386p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0i386p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0m68kp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0mips64ebp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0mips64ebp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0mips64ebp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0mipselp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0mipselp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0powerpcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0powerpcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sh3elp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sh3elp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sh3elp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sparc64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sparc64p5-XML-Parser-Lite-0.722nb1.tgz
NetBSD 9.0sparc64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sparc64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sparcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sparcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0sparcp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0vaxp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0vaxp5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz
NetBSD 9.0x86_64p5-XML-Parser-Lite-0.722nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.