textproc/expat - The NetBSD Packages Collection

XML parser library written in C

This is James Clark's expat XML parser library in C. It is a stream oriented
parser that requires setting handlers to deal with the structure that the
parser discovers in the document.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfexpat-2.4.1.tgz
NetBSD 8.0earmv7hfexpat-2.2.10nb1.tgz
NetBSD 8.0earmv7hfexpat-2.4.1.tgz
NetBSD 8.0i386expat-2.2.10nb1.tgz
NetBSD 8.0i386expat-2.4.1.tgz
NetBSD 8.0powerpcexpat-2.2.10nb1.tgz
NetBSD 8.0powerpcexpat-2.4.1.tgz
NetBSD 8.0powerpcexpat-2.4.1.tgz
NetBSD 8.0powerpcexpat-2.4.1.tgz
NetBSD 8.0x86_64expat-2.2.10nb1.tgz
NetBSD 8.0x86_64expat-2.4.1.tgz
NetBSD 9.0aarch64expat-2.4.1.tgz
NetBSD 9.0aarch64expat-2.2.10nb1.tgz
NetBSD 9.0aarch64expat-2.4.1.tgz
NetBSD 9.0alphaexpat-2.4.1.tgz
NetBSD 9.0alphaexpat-2.2.10nb1.tgz
NetBSD 9.0alphaexpat-2.4.1.tgz
NetBSD 9.0earmexpat-2.2.10nb1.tgz
NetBSD 9.0earmexpat-2.4.1.tgz
NetBSD 9.0earmexpat-2.4.1.tgz
NetBSD 9.0earmv6hfexpat-2.4.1.tgz
NetBSD 9.0earmv6hfexpat-2.2.10nb1.tgz
NetBSD 9.0earmv6hfexpat-2.4.1.tgz
NetBSD 9.0earmv7hfexpat-2.4.1.tgz
NetBSD 9.0earmv7hfexpat-2.2.10nb1.tgz
NetBSD 9.0earmv7hfexpat-2.4.1.tgz
NetBSD 9.0earmv7hfexpat-2.4.1.tgz
NetBSD 9.0i386expat-2.2.10nb1.tgz
NetBSD 9.0i386expat-2.4.1.tgz
NetBSD 9.0i386expat-2.4.1.tgz
NetBSD 9.0mips64ebexpat-2.4.1.tgz
NetBSD 9.0mips64ebexpat-2.2.9.tgz
NetBSD 9.0mips64ebexpat-2.2.10nb1.tgz
NetBSD 9.0mips64ebexpat-2.2.10nb1.tgz
NetBSD 9.0mips64ebexpat-2.4.1.tgz
NetBSD 9.0mipselexpat-2.4.1.tgz
NetBSD 9.0mipselexpat-2.2.10nb1.tgz
NetBSD 9.0mipselexpat-2.2.10nb1.tgz
NetBSD 9.0mipselexpat-2.4.1.tgz
NetBSD 9.0powerpcexpat-2.4.1.tgz
NetBSD 9.0powerpcexpat-2.2.10nb1.tgz
NetBSD 9.0powerpcexpat-2.4.1.tgz
NetBSD 9.0powerpcexpat-2.4.1.tgz
NetBSD 9.0sh3elexpat-2.4.1.tgz
NetBSD 9.0sh3elexpat-2.2.10nb1.tgz
NetBSD 9.0sh3elexpat-2.2.10nb1.tgz
NetBSD 9.0sh3elexpat-2.4.1.tgz
NetBSD 9.0sparc64expat-2.4.1.tgz
NetBSD 9.0sparc64expat-2.2.10nb1.tgz
NetBSD 9.0sparc64expat-2.4.1.tgz
NetBSD 9.0sparcexpat-2.4.1.tgz
NetBSD 9.0sparcexpat-2.2.9.tgz
NetBSD 9.0sparcexpat-2.2.10nb1.tgz
NetBSD 9.0sparcexpat-2.2.10nb1.tgz
NetBSD 9.0sparcexpat-2.4.1.tgz
NetBSD 9.0vaxexpat-2.2.10nb1.tgz
NetBSD 9.0vaxexpat-2.2.10nb1.tgz
NetBSD 9.0vaxexpat-2.4.1.tgz
NetBSD 9.0vaxexpat-2.4.1.tgz
NetBSD 9.0x86_64expat-2.4.1.tgz
NetBSD 9.0x86_64expat-2.4.1.tgz
NetBSD 9.0x86_64expat-2.2.10nb1.tgz
NetBSD 9.0x86_64expat-2.4.1.tgz
NetBSD 9.0x86_64expat-2.4.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.