sysutils/s6 - The NetBSD Packages Collection

The s6 supervision suite

s6 is a small suite of programs for UNIX, designed to allow process
supervision (a.k.a service supervision), in the line of daemontools and
runit, as well as various operations on processes and daemons. It is meant
to be a toolbox for low-level process and service administration, providing
different sets of independent tools that can be used within or without the
framework, and that can be assembled together to achieve powerful
functionality with a very small amount of code.

Build dependencies

lang/execline pkgtools/cwrappers devel/gmake

Runtime dependencies

devel/skalibs

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfs6-2.10.0.3.tgz
NetBSD 8.0earmv7hfs6-2.10.0.2nb1.tgz
NetBSD 8.0earmv7hfs6-2.10.0.3.tgz
NetBSD 9.0aarch64s6-2.10.0.3.tgz
NetBSD 9.0aarch64s6-2.10.0.2nb1.tgz
NetBSD 9.0aarch64s6-2.10.0.3.tgz
NetBSD 9.0alphas6-2.10.0.3.tgz
NetBSD 9.0alphas6-2.10.0.2nb1.tgz
NetBSD 9.0alphas6-2.10.0.3.tgz
NetBSD 9.0earms6-2.10.0.2nb1.tgz
NetBSD 9.0earms6-2.10.0.3.tgz
NetBSD 9.0earms6-2.10.0.3.tgz
NetBSD 9.0earmv6hfs6-2.10.0.3.tgz
NetBSD 9.0earmv6hfs6-2.10.0.2nb1.tgz
NetBSD 9.0earmv6hfs6-2.10.0.3.tgz
NetBSD 9.0earmv7hfs6-2.10.0.3.tgz
NetBSD 9.0earmv7hfs6-2.10.0.2nb1.tgz
NetBSD 9.0earmv7hfs6-2.10.0.3.tgz
NetBSD 9.0earmv7hfs6-2.10.0.3.tgz
NetBSD 9.0i386s6-2.10.0.2nb1.tgz
NetBSD 9.0i386s6-2.10.0.3.tgz
NetBSD 9.0i386s6-2.10.0.3.tgz
NetBSD 9.0mips64ebs6-2.10.0.3.tgz
NetBSD 9.0mips64ebs6-2.9.2.0.tgz
NetBSD 9.0mips64ebs6-2.10.0.2nb1.tgz
NetBSD 9.0mips64ebs6-2.10.0.3.tgz
NetBSD 9.0powerpcs6-2.10.0.3.tgz
NetBSD 9.0powerpcs6-2.10.0.2nb1.tgz
NetBSD 9.0powerpcs6-2.10.0.3.tgz
NetBSD 9.0powerpcs6-2.10.0.3.tgz
NetBSD 9.0sparc64s6-2.10.0.3.tgz
NetBSD 9.0sparc64s6-2.10.0.2nb1.tgz
NetBSD 9.0sparc64s6-2.10.0.3.tgz
NetBSD 9.0sparcs6-2.9.2.0.tgz
NetBSD 9.0sparcs6-2.10.0.2nb1.tgz
NetBSD 9.0sparcs6-2.10.0.3.tgz
NetBSD 9.0vaxs6-2.10.0.2nb1.tgz
NetBSD 9.0x86_64s6-2.10.0.3.tgz
NetBSD 9.0x86_64s6-2.10.0.3.tgz
NetBSD 9.0x86_64s6-2.10.0.2nb1.tgz
NetBSD 9.0x86_64s6-2.10.0.3.tgz
NetBSD 9.0x86_64s6-2.10.0.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.