sysutils/magicrescue - The NetBSD Packages Collection

Recover files from a block device by scanning for magic bytes

Magic Rescue scans a block device for file types it knows how to
recover and calls an external program to extract them.  It looks
at "magic bytes" in file contents, so it can be used both as an
undelete utility and for recovering a corrupted drive or partition.
As long as the file data is there, it will find it.

It works on any file system, but on very fragmented file systems
it can only recover the first chunk of each file.  Practical
experience (this program was not written for fun) shows, however,
that chunks of 30-50MB are not uncommon.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmagicrescue-1.1.4nb9.tgz
NetBSD 8.0earmv7hfmagicrescue-1.1.4nb8.tgz
NetBSD 8.0earmv7hfmagicrescue-1.1.4nb9.tgz
NetBSD 8.0i386magicrescue-1.1.4nb8.tgz
NetBSD 8.0i386magicrescue-1.1.4nb9.tgz
NetBSD 8.0powerpcmagicrescue-1.1.4nb8.tgz
NetBSD 8.0powerpcmagicrescue-1.1.4nb9.tgz
NetBSD 8.0powerpcmagicrescue-1.1.4nb9.tgz
NetBSD 8.0powerpcmagicrescue-1.1.4nb9.tgz
NetBSD 8.0x86_64magicrescue-1.1.4nb8.tgz
NetBSD 8.0x86_64magicrescue-1.1.4nb9.tgz
NetBSD 9.0aarch64magicrescue-1.1.4nb9.tgz
NetBSD 9.0aarch64magicrescue-1.1.4nb8.tgz
NetBSD 9.0aarch64magicrescue-1.1.4nb9.tgz
NetBSD 9.0alphamagicrescue-1.1.4nb9.tgz
NetBSD 9.0alphamagicrescue-1.1.4nb8.tgz
NetBSD 9.0alphamagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmmagicrescue-1.1.4nb8.tgz
NetBSD 9.0earmmagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmmagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmv6hfmagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmv6hfmagicrescue-1.1.4nb8.tgz
NetBSD 9.0earmv6hfmagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmv7hfmagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmv7hfmagicrescue-1.1.4nb8.tgz
NetBSD 9.0earmv7hfmagicrescue-1.1.4nb9.tgz
NetBSD 9.0earmv7hfmagicrescue-1.1.4nb9.tgz
NetBSD 9.0i386magicrescue-1.1.4nb8.tgz
NetBSD 9.0i386magicrescue-1.1.4nb9.tgz
NetBSD 9.0i386magicrescue-1.1.4nb9.tgz
NetBSD 9.0mips64ebmagicrescue-1.1.4nb9.tgz
NetBSD 9.0mips64ebmagicrescue-1.1.4nb8.tgz
NetBSD 9.0mips64ebmagicrescue-1.1.4nb8.tgz
NetBSD 9.0mips64ebmagicrescue-1.1.4nb8.tgz
NetBSD 9.0mips64ebmagicrescue-1.1.4nb9.tgz
NetBSD 9.0powerpcmagicrescue-1.1.4nb9.tgz
NetBSD 9.0powerpcmagicrescue-1.1.4nb8.tgz
NetBSD 9.0powerpcmagicrescue-1.1.4nb9.tgz
NetBSD 9.0powerpcmagicrescue-1.1.4nb9.tgz
NetBSD 9.0sparc64magicrescue-1.1.4nb9.tgz
NetBSD 9.0sparc64magicrescue-1.1.4nb8.tgz
NetBSD 9.0sparc64magicrescue-1.1.4nb9.tgz
NetBSD 9.0sparcmagicrescue-1.1.4nb9.tgz
NetBSD 9.0sparcmagicrescue-1.1.4nb8.tgz
NetBSD 9.0sparcmagicrescue-1.1.4nb8.tgz
NetBSD 9.0sparcmagicrescue-1.1.4nb9.tgz
NetBSD 9.0x86_64magicrescue-1.1.4nb9.tgz
NetBSD 9.0x86_64magicrescue-1.1.4nb9.tgz
NetBSD 9.0x86_64magicrescue-1.1.4nb8.tgz
NetBSD 9.0x86_64magicrescue-1.1.4nb9.tgz
NetBSD 9.0x86_64magicrescue-1.1.4nb9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.