security/snallygaster - The NetBSD Packages Collection

Tool to scan for secret files on HTTP servers

snallygaster is a tool that looks for files accessible on web servers that
shouldn't be public and can pose a security risk.

Typical examples include publicly accessible git repositories, backup files
potentially containing passwords or database dumps. In addition it contains a
few checks for other security vulnerabilities.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/py-beautifulsoup4 net/py-dns www/py-urllib3 devel/py-setuptools lang/python39 lang/python39

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 8.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 8.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 8.0i386snallygaster-0.0.9nb1.tgz
NetBSD 8.0i386snallygaster-0.0.9nb1.tgz
NetBSD 8.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 8.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 8.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 8.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 8.0x86_64snallygaster-0.0.9nb1.tgz
NetBSD 8.0x86_64snallygaster-0.0.9nb1.tgz
NetBSD 9.0aarch64snallygaster-0.0.9nb1.tgz
NetBSD 9.0aarch64snallygaster-0.0.9nb1.tgz
NetBSD 9.0aarch64snallygaster-0.0.9nb1.tgz
NetBSD 9.0alphasnallygaster-0.0.9nb1.tgz
NetBSD 9.0alphasnallygaster-0.0.9nb1.tgz
NetBSD 9.0alphasnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv6hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv6hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv6hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0earmv7hfsnallygaster-0.0.9nb1.tgz
NetBSD 9.0i386snallygaster-0.0.9nb1.tgz
NetBSD 9.0i386snallygaster-0.0.9nb1.tgz
NetBSD 9.0i386snallygaster-0.0.9nb1.tgz
NetBSD 9.0mips64ebsnallygaster-0.0.9nb1.tgz
NetBSD 9.0mips64ebsnallygaster-0.0.8.tgz
NetBSD 9.0mips64ebsnallygaster-0.0.9nb1.tgz
NetBSD 9.0mips64ebsnallygaster-0.0.9nb1.tgz
NetBSD 9.0mips64ebsnallygaster-0.0.9nb1.tgz
NetBSD 9.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0powerpcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0sparc64snallygaster-0.0.9nb1.tgz
NetBSD 9.0sparc64snallygaster-0.0.9nb1.tgz
NetBSD 9.0sparc64snallygaster-0.0.9nb1.tgz
NetBSD 9.0sparcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0sparcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0sparcsnallygaster-0.0.9nb1.tgz
NetBSD 9.0x86_64snallygaster-0.0.9nb1.tgz
NetBSD 9.0x86_64snallygaster-0.0.9nb1.tgz
NetBSD 9.0x86_64snallygaster-0.0.9nb1.tgz
NetBSD 9.0x86_64snallygaster-0.0.9nb1.tgz
NetBSD 9.0x86_64snallygaster-0.0.9nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.