security/php-oauth1 - The NetBSD Packages Collection

PHP oauth consumer extension

OAuth is an authorization protocol built on top of HTTP which allows
applications to securely access data without having to store usernames
and passwords.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf

Runtime dependencies

lang/php56 www/curl lang/php56 www/curl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfphp56-oauth-1.2.3nb19.tgz
NetBSD 8.0earmv7hfphp56-oauth-1.2.3nb18.tgz
NetBSD 8.0earmv7hfphp56-oauth-1.2.3nb19.tgz
NetBSD 8.0i386php56-oauth-1.2.3nb18.tgz
NetBSD 8.0i386php56-oauth-1.2.3nb19.tgz
NetBSD 8.0powerpcphp56-oauth-1.2.3nb18.tgz
NetBSD 8.0powerpcphp56-oauth-1.2.3nb19.tgz
NetBSD 8.0powerpcphp56-oauth-1.2.3nb19.tgz
NetBSD 8.0powerpcphp56-oauth-1.2.3nb19.tgz
NetBSD 8.0x86_64php56-oauth-1.2.3nb18.tgz
NetBSD 8.0x86_64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0aarch64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0aarch64php56-oauth-1.2.3nb18.tgz
NetBSD 9.0aarch64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0alphaphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0alphaphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0alphaphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0earmv6hfphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0earmv6hfphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0earmv6hfphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0earmv7hfphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0earmv7hfphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0earmv7hfphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0earmv7hfphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0i386php56-oauth-1.2.3nb18.tgz
NetBSD 9.0i386php56-oauth-1.2.3nb19.tgz
NetBSD 9.0i386php56-oauth-1.2.3nb19.tgz
NetBSD 9.0mips64ebphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0mips64ebphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0mips64ebphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0mips64ebphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0mips64ebphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0powerpcphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0powerpcphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0powerpcphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0powerpcphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0sparc64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0sparc64php56-oauth-1.2.3nb18.tgz
NetBSD 9.0sparc64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0sparcphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0sparcphp56-oauth-1.2.3nb18.tgz
NetBSD 9.0sparcphp56-oauth-1.2.3nb19.tgz
NetBSD 9.0x86_64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0x86_64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0x86_64php56-oauth-1.2.3nb18.tgz
NetBSD 9.0x86_64php56-oauth-1.2.3nb19.tgz
NetBSD 9.0x86_64php56-oauth-1.2.3nb19.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.