security/p5-GSSAPI - The NetBSD Packages Collection

Perl extension providing access to the GSSAPIv2 library

Gives access to the routines of the GSSAPI library, as described in
rfc2743 and rfc2744 and implemented by the Kerberos-1.2 distribution
from MIT.
Since 0.14 it also compiles and works with Heimdal. Lacks of Heimdal
support are gss_release_oid(), gss_str_to_oid() and fail of some tests.
The API presented by this module is a mildly object oriented
reinterpretation of the C API, where opaque C structures are Perl
objects, but the style of function call has been left mostly untouched.
As a result, most routines modify one or more of the parameters passed
to them, reflecting the C call-by-reference (or call-by-value-return)
semantics.
All users of this module are therefore strongly advised to localize all
usage of these routines to minimize pain if and when the API changes.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-GSSAPI-0.28nb12.tgz
NetBSD 8.0earmv7hfp5-GSSAPI-0.28nb11.tgz
NetBSD 8.0earmv7hfp5-GSSAPI-0.28nb12.tgz
NetBSD 8.0i386p5-GSSAPI-0.28nb11.tgz
NetBSD 8.0i386p5-GSSAPI-0.28nb12.tgz
NetBSD 8.0powerpcp5-GSSAPI-0.28nb11.tgz
NetBSD 8.0powerpcp5-GSSAPI-0.28nb12.tgz
NetBSD 8.0powerpcp5-GSSAPI-0.28nb12.tgz
NetBSD 8.0powerpcp5-GSSAPI-0.28nb12.tgz
NetBSD 8.0x86_64p5-GSSAPI-0.28nb11.tgz
NetBSD 8.0x86_64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0aarch64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0aarch64p5-GSSAPI-0.28nb11.tgz
NetBSD 9.0aarch64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0alphap5-GSSAPI-0.28nb12.tgz
NetBSD 9.0alphap5-GSSAPI-0.28nb11.tgz
NetBSD 9.0alphap5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0earmp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmv6hfp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmv6hfp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0earmv6hfp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmv7hfp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmv7hfp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0earmv7hfp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0earmv7hfp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0i386p5-GSSAPI-0.28nb11.tgz
NetBSD 9.0i386p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0m68kp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0m68kp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0m68kp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0m68kp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0mips64ebp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0mips64ebp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0mips64ebp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0mips64ebp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0mips64ebp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0mipselp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0mipselp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0mipselp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0mipselp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0powerpcp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0powerpcp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0powerpcp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0powerpcp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0sh3elp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0sh3elp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sh3elp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sh3elp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sh3elp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0sparc64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0sparc64p5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sparc64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0sparcp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0sparcp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sparcp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sparcp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0sparcp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0vaxp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0vaxp5-GSSAPI-0.28nb11.tgz
NetBSD 9.0vaxp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0vaxp5-GSSAPI-0.28nb12.tgz
NetBSD 9.0x86_64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0x86_64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0x86_64p5-GSSAPI-0.28nb11.tgz
NetBSD 9.0x86_64p5-GSSAPI-0.28nb12.tgz
NetBSD 9.0x86_64p5-GSSAPI-0.28nb12.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.