security/libsecp256k1 - The NetBSD Packages Collection

Optimized C library for EC operations on curve secp256k1

Optimized C library for ECDSA signatures and secret/public key operations on
curve secp256k1.

This library is intended to be the highest quality publicly available library
for cryptography on the secp256k1 curve. However, the primary focus of its
development has been for usage in the Bitcoin system and usage unlike Bitcoin's
may be less well tested, verified, or suffer from a less well thought out
interface. Correct usage requires some care and consideration that the library
is fit for your application's purpose.

Features:
* secp256k1 ECDSA signing/verification and key generation.
* Additive and multiplicative tweaking of secret/public keys.
* Serialization/parsing of secret keys, public keys, signatures.
* Constant time, constant memory access signing and public key generation.
* Derandomized ECDSA (via RFC6979 or with a caller provided function.)
* Very efficient implementation.
* Suitable for embedded systems.
* Optional module for public key recovery.
* Optional module for ECDH key exchange.

Experimental features have not received enough scrutiny to satisfy the standard
of quality of this library but are made available for testing and review by the
community. The APIs of these features should not be considered stable.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/gmake devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 8.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 8.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 8.0i386libsecp256k1-0.1.tgz
NetBSD 8.0i386libsecp256k1-0.1.tgz
NetBSD 8.0powerpclibsecp256k1-0.1.tgz
NetBSD 8.0powerpclibsecp256k1-0.1.tgz
NetBSD 8.0powerpclibsecp256k1-0.1.tgz
NetBSD 8.0powerpclibsecp256k1-0.1.tgz
NetBSD 8.0x86_64libsecp256k1-0.1.tgz
NetBSD 8.0x86_64libsecp256k1-0.1.tgz
NetBSD 9.0aarch64libsecp256k1-0.1.tgz
NetBSD 9.0aarch64libsecp256k1-0.1.tgz
NetBSD 9.0aarch64libsecp256k1-0.1.tgz
NetBSD 9.0alphalibsecp256k1-0.1.tgz
NetBSD 9.0alphalibsecp256k1-0.1.tgz
NetBSD 9.0alphalibsecp256k1-0.1.tgz
NetBSD 9.0earmlibsecp256k1-0.1.tgz
NetBSD 9.0earmlibsecp256k1-0.1.tgz
NetBSD 9.0earmlibsecp256k1-0.1.tgz
NetBSD 9.0earmv6hflibsecp256k1-0.1.tgz
NetBSD 9.0earmv6hflibsecp256k1-0.1.tgz
NetBSD 9.0earmv6hflibsecp256k1-0.1.tgz
NetBSD 9.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 9.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 9.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 9.0earmv7hflibsecp256k1-0.1.tgz
NetBSD 9.0i386libsecp256k1-0.1.tgz
NetBSD 9.0i386libsecp256k1-0.1.tgz
NetBSD 9.0mips64eblibsecp256k1-0.1.tgz
NetBSD 9.0mips64eblibsecp256k1-0.1.tgz
NetBSD 9.0mips64eblibsecp256k1-0.1.tgz
NetBSD 9.0mips64eblibsecp256k1-0.1.tgz
NetBSD 9.0powerpclibsecp256k1-0.1.tgz
NetBSD 9.0powerpclibsecp256k1-0.1.tgz
NetBSD 9.0powerpclibsecp256k1-0.1.tgz
NetBSD 9.0powerpclibsecp256k1-0.1.tgz
NetBSD 9.0sh3ellibsecp256k1-0.1.tgz
NetBSD 9.0sh3ellibsecp256k1-0.1.tgz
NetBSD 9.0sh3ellibsecp256k1-0.1.tgz
NetBSD 9.0sparc64libsecp256k1-0.1.tgz
NetBSD 9.0sparc64libsecp256k1-0.1.tgz
NetBSD 9.0sparc64libsecp256k1-0.1.tgz
NetBSD 9.0sparclibsecp256k1-0.1.tgz
NetBSD 9.0sparclibsecp256k1-0.1.tgz
NetBSD 9.0sparclibsecp256k1-0.1.tgz
NetBSD 9.0sparclibsecp256k1-0.1.tgz
NetBSD 9.0vaxlibsecp256k1-0.1.tgz
NetBSD 9.0vaxlibsecp256k1-0.1.tgz
NetBSD 9.0vaxlibsecp256k1-0.1.tgz
NetBSD 9.0x86_64libsecp256k1-0.1.tgz
NetBSD 9.0x86_64libsecp256k1-0.1.tgz
NetBSD 9.0x86_64libsecp256k1-0.1.tgz
NetBSD 9.0x86_64libsecp256k1-0.1.tgz
NetBSD 9.0x86_64libsecp256k1-0.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.