security/gnutls - The NetBSD Packages Collection

Transport Layer Security library

GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and SSL
3.0 protocols. The library does not include any patented algorithms and is
available under the GNU Lesser GPL license.

Important features of the GnuTLS library include:
- Thread safety
- Support for both TLS 1.0 and SSL 3.0 protocols
- Support for both X.509 and OpenPGP certificates
- Support for basic parsing and verification of certificates
- Support for SRP for TLS authentication
- Support for TLS Extension mechanism
- Support for TLS Compression Methods

Additionally GnuTLS provides an emulation API for the widely used OpenSSL
library, to ease integration with existing applications.

Build dependencies

pkgtools/cwrappers devel/libtool-base shells/bash devel/gmake textproc/gsed lang/perl5 devel/pkgconf

Runtime dependencies

security/mozilla-rootcerts archivers/lzo devel/gmp devel/gmp devel/gmp devel/libcfg+ security/libtasn1 security/libtasn1 security/nettle security/nettle security/p11-kit security/p11-kit security/p11-kit textproc/libunistring devel/gmp devel/libcfg+ security/libtasn1 security/p11-kit textproc/libunistring

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgnutls-3.7.0.tgz
NetBSD 8.0earmv7hfgnutls-3.6.15.tgz
NetBSD 8.0earmv7hfgnutls-3.7.1.tgz
NetBSD 8.0earmv7hfgnutls-3.7.0.tgz
NetBSD 8.0i386gnutls-3.6.15.tgz
NetBSD 8.0i386gnutls-3.7.0.tgz
NetBSD 8.0powerpcgnutls-3.6.15.tgz
NetBSD 8.0powerpcgnutls-3.7.0.tgz
NetBSD 8.0powerpcgnutls-3.7.0.tgz
NetBSD 8.0x86_64gnutls-3.6.15.tgz
NetBSD 8.0x86_64gnutls-3.7.0.tgz
NetBSD 9.0aarch64gnutls-3.7.1.tgz
NetBSD 9.0aarch64gnutls-3.6.15.tgz
NetBSD 9.0aarch64gnutls-3.7.0.tgz
NetBSD 9.0alphagnutls-3.7.1.tgz
NetBSD 9.0alphagnutls-3.6.15.tgz
NetBSD 9.0alphagnutls-3.7.0.tgz
NetBSD 9.0earmgnutls-3.6.15.tgz
NetBSD 9.0earmgnutls-3.7.0.tgz
NetBSD 9.0earmgnutls-3.7.1.tgz
NetBSD 9.0earmv6hfgnutls-3.7.1.tgz
NetBSD 9.0earmv6hfgnutls-3.6.15.tgz
NetBSD 9.0earmv6hfgnutls-3.7.0.tgz
NetBSD 9.0earmv6hfgnutls-3.7.0.tgz
NetBSD 9.0earmv7hfgnutls-3.7.1.tgz
NetBSD 9.0earmv7hfgnutls-3.6.15.tgz
NetBSD 9.0earmv7hfgnutls-3.7.0.tgz
NetBSD 9.0earmv7hfgnutls-3.7.0.tgz
NetBSD 9.0earmv7hfgnutls-3.7.0.tgz
NetBSD 9.0i386gnutls-3.6.15.tgz
NetBSD 9.0i386gnutls-3.7.0.tgz
NetBSD 9.0m68kgnutls-3.7.1.tgz
NetBSD 9.0m68kgnutls-3.6.15.tgz
NetBSD 9.0m68kgnutls-3.7.0.tgz
NetBSD 9.0mips64ebgnutls-3.7.1.tgz
NetBSD 9.0mips64ebgnutls-3.6.15.tgz
NetBSD 9.0mips64ebgnutls-3.7.0.tgz
NetBSD 9.0mipselgnutls-3.7.0.tgz
NetBSD 9.0mipselgnutls-3.7.1.tgz
NetBSD 9.0powerpcgnutls-3.7.0.tgz
NetBSD 9.0powerpcgnutls-3.6.15.tgz
NetBSD 9.0sh3elgnutls-3.6.15.tgz
NetBSD 9.0sh3elgnutls-3.7.0.tgz
NetBSD 9.0sh3elgnutls-3.7.1.tgz
NetBSD 9.0sparc64gnutls-3.7.1.tgz
NetBSD 9.0sparc64gnutls-3.6.14.tgz
NetBSD 9.0sparc64gnutls-3.6.15.tgz
NetBSD 9.0sparc64gnutls-3.7.0.tgz
NetBSD 9.0sparcgnutls-3.7.1.tgz
NetBSD 9.0sparcgnutls-3.6.15.tgz
NetBSD 9.0sparcgnutls-3.7.0.tgz
NetBSD 9.0vaxgnutls-3.7.0.tgz
NetBSD 9.0x86_64gnutls-3.6.15.tgz
NetBSD 9.0x86_64gnutls-3.7.0.tgz
NetBSD 9.0x86_64gnutls-3.7.0.tgz
NetBSD 9.0x86_64gnutls-3.6.15.tgz
NetBSD 9.0x86_64gnutls-3.7.0.tgz
NetBSD 9.0x86_64gnutls-3.7.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

dane
Enable DANE support.
guile
Enable support for GUILE.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.