security/egd - The NetBSD Packages Collection

EGD: Entropy Gathering Daemon

This is a perl program to collect entropy from a running Unix-like system,
mostly through various stats calls (vmstat and friends). The output is
hashed into a pool, stirred with an SHA1 hash, and used to provide
(theoretically) high-quality random data to callers over a UNIX- or TCP-
socket interface. This aims to provide functionality similar to the Linux
/dev/random device, but implemented in a fairly-portable user-space daemon
so that it can run on many unix-like systems. See the README for common
usage details.

Build dependencies

pkgtools/cwrappers lang/perl5

Runtime dependencies

security/p5-SHA lang/perl5 lang/perl5

Available binary packages

aarch64:egd-0.8nb10.tgz(NetBSD 9.0)
aarch64:egd-0.8nb11.tgz(NetBSD 9.0)
aarch64:egd-0.8nb11.tgz(NetBSD 9.0)
alpha:egd-0.8nb11.tgz(NetBSD 9.0)
alpha:egd-0.8nb11.tgz(NetBSD 9.0)
earmv6hf:egd-0.8nb11.tgz(NetBSD 9.0)
earmv6hf:egd-0.8nb10.tgz(NetBSD 9.0)
earmv6hf:egd-0.8nb11.tgz(NetBSD 9.0)
earmv6hf:egd-0.8nb11.tgz(NetBSD 9.0)
earmv7hf:egd-0.8nb11.tgz(NetBSD 8.0)
earmv7hf:egd-0.8nb10.tgz(NetBSD 8.0)
earmv7hf:egd-0.8nb10.tgz(NetBSD 8.0)
earmv7hf:egd-0.8nb11.tgz(NetBSD 8.0)
earmv7hf:egd-0.8nb11.tgz(NetBSD 9.0)
earmv7hf:egd-0.8nb10.tgz(NetBSD 9.0)
earmv7hf:egd-0.8nb10.tgz(NetBSD 9.0)
earmv7hf:egd-0.8nb11.tgz(NetBSD 9.0)
earmv7hf:egd-0.8nb11.tgz(NetBSD 9.0)
i386:egd-0.8nb10.tgz(NetBSD 8.0)
i386:egd-0.8nb11.tgz(NetBSD 8.0)
i386:egd-0.8nb11.tgz(NetBSD 8.0)
i386:egd-0.8nb10.tgz(NetBSD 9.0)
i386:egd-0.8nb11.tgz(NetBSD 9.0)
i386:egd-0.8nb11.tgz(NetBSD 9.0)
mips64eb:egd-0.8nb11.tgz(NetBSD 9.0)
powerpc:egd-0.8nb10.tgz(NetBSD 8.0)
powerpc:egd-0.8nb11.tgz(NetBSD 8.0)
powerpc:egd-0.8nb11.tgz(NetBSD 8.0)
powerpc:egd-0.8nb11.tgz(NetBSD 9.0)
powerpc:egd-0.8nb10.tgz(NetBSD 9.0)
sparc64:egd-0.8nb11.tgz(NetBSD 9.0)
sparc64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 8.0)
x86_64:egd-0.8nb10.tgz(NetBSD 8.0)
x86_64:egd-0.8nb11.tgz(NetBSD 8.0)
x86_64:egd-0.8nb10.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)
x86_64:egd-0.8nb11.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]