net/wide-dhcpv6 - The NetBSD Packages Collection

DHCP6 client, server and relay agent by WIDE project

WIDE-DHCPv6 is an open-source implementation of Dynamic Host Configuration
Protocol for IPv6 (DHCPv6) developed by the KAME project.

The implementation mainly conforms to the following standards:

- RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
- RFC3319: Dynamic Host Configuration Protocol (DHCPv6) Options
	   for Session Initiation Protocol (SIP) Servers
- RFC3633: IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP)
- RFC3646: DNS Configuration options for Dynamic Host
	   Configuration Protocol for IPv6 (DHCPv6)
- RFC4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6
- RFC4242: Information Refresh Time Option for Dynamic Host
	   Configuration Protocol for IPv6 (DHCPv6)

All the components of the main protocol are provided, i.e., DHCPv6 clients,
servers, and relay agents. Supported message types are as follows:

  Solicit, Advertise, Request, Renew, Rebind, Release, Reply,
  Information-request, Relay-forward and Relay-reply.

Note that the current implementation does not support IPv6 temporary address
allocation by DHCPv6, and there is no plan to implement that feature at the
moment.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0i386wide-dhcpv6-20080615nb1.tgz
NetBSD 8.0i386wide-dhcpv6-20080615nb1.tgz
NetBSD 8.0i386wide-dhcpv6-20080615nb1.tgz
NetBSD 8.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 8.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 8.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 8.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0aarch64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0aarch64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0aarch64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0alphawide-dhcpv6-20080615nb1.tgz
NetBSD 9.0alphawide-dhcpv6-20080615nb1.tgz
NetBSD 9.0alphawide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv6hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv6hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv6hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv6hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0earmv7hfwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0i386wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0i386wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0i386wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0mips64ebwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0mips64ebwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0mips64ebwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0powerpcwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0sparc64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0sparc64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0sparc64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0sparc64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0sparcwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0sparcwide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz
NetBSD 9.0x86_64wide-dhcpv6-20080615nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.