net/ruby-net-ldap - The NetBSD Packages Collection

Client access for the LDAP

Net::LDAP for Ruby (also called net-ldap) implements client access for the
Lightweight Directory Access Protocol (LDAP), an IETF standard protocol for
accessing distributed directory services. Net::LDAP is written completely in
Ruby with no external dependencies. It supports most LDAP client features
and a subset of server features as well.

Net::LDAP has been tested against modern popular LDAP servers including
OpenLDAP and Active Directory. The current release is mostly compliant with
earlier versions of the IETF LDAP RFCs (2251-2256, 2829-2830, 3377, and 3771).
Our roadmap for Net::LDAP 1.0 is to gain full client compliance with
the most recent LDAP RFCs (4510-4519, plus portions of 4520-4532).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/ruby26-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-net-ldap-0.16.3.tgz
NetBSD 8.0earmv7hfruby26-net-ldap-0.16.3.tgz
NetBSD 8.0earmv7hfruby27-net-ldap-0.16.3.tgz
NetBSD 8.0earmv7hfruby25-net-ldap-0.16.3.tgz
NetBSD 8.0earmv7hfruby26-net-ldap-0.16.3.tgz
NetBSD 8.0earmv7hfruby27-net-ldap-0.16.3.tgz
NetBSD 8.0earmv7hfruby25-net-ldap-0.17.0.tgz
NetBSD 8.0earmv7hfruby26-net-ldap-0.17.0.tgz
NetBSD 8.0earmv7hfruby27-net-ldap-0.17.0.tgz
NetBSD 8.0i386ruby25-net-ldap-0.16.3.tgz
NetBSD 8.0i386ruby26-net-ldap-0.16.3.tgz
NetBSD 8.0i386ruby27-net-ldap-0.16.3.tgz
NetBSD 8.0i386ruby25-net-ldap-0.16.3.tgz
NetBSD 8.0i386ruby26-net-ldap-0.16.3.tgz
NetBSD 8.0i386ruby27-net-ldap-0.16.3.tgz
NetBSD 8.0i386ruby25-net-ldap-0.17.0.tgz
NetBSD 8.0i386ruby26-net-ldap-0.17.0.tgz
NetBSD 8.0i386ruby27-net-ldap-0.17.0.tgz
NetBSD 8.0powerpcruby25-net-ldap-0.16.3.tgz
NetBSD 8.0powerpcruby26-net-ldap-0.16.3.tgz
NetBSD 8.0powerpcruby27-net-ldap-0.16.3.tgz
NetBSD 8.0powerpcruby25-net-ldap-0.17.0.tgz
NetBSD 8.0powerpcruby26-net-ldap-0.17.0.tgz
NetBSD 8.0powerpcruby27-net-ldap-0.17.0.tgz
NetBSD 8.0powerpcruby25-net-ldap-0.16.3.tgz
NetBSD 8.0powerpcruby26-net-ldap-0.16.3.tgz
NetBSD 8.0powerpcruby27-net-ldap-0.16.3.tgz
NetBSD 8.0powerpcruby25-net-ldap-0.17.0.tgz
NetBSD 8.0powerpcruby26-net-ldap-0.17.0.tgz
NetBSD 8.0powerpcruby27-net-ldap-0.17.0.tgz
NetBSD 8.0x86_64ruby25-net-ldap-0.17.0.tgz
NetBSD 8.0x86_64ruby26-net-ldap-0.17.0.tgz
NetBSD 8.0x86_64ruby27-net-ldap-0.17.0.tgz
NetBSD 8.0x86_64ruby25-net-ldap-0.16.3.tgz
NetBSD 8.0x86_64ruby26-net-ldap-0.16.3.tgz
NetBSD 8.0x86_64ruby27-net-ldap-0.16.3.tgz
NetBSD 8.0x86_64ruby25-net-ldap-0.16.3.tgz
NetBSD 8.0x86_64ruby26-net-ldap-0.16.3.tgz
NetBSD 8.0x86_64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0aarch64ruby25-net-ldap-0.17.0.tgz
NetBSD 9.0aarch64ruby26-net-ldap-0.17.0.tgz
NetBSD 9.0aarch64ruby27-net-ldap-0.17.0.tgz
NetBSD 9.0aarch64ruby30-net-ldap-0.17.0.tgz
NetBSD 9.0aarch64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0aarch64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0aarch64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0aarch64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0aarch64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0aarch64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0alpharuby25-net-ldap-0.17.0.tgz
NetBSD 9.0alpharuby26-net-ldap-0.17.0.tgz
NetBSD 9.0alpharuby27-net-ldap-0.17.0.tgz
NetBSD 9.0alpharuby25-net-ldap-0.16.3.tgz
NetBSD 9.0alpharuby26-net-ldap-0.16.3.tgz
NetBSD 9.0alpharuby27-net-ldap-0.16.3.tgz
NetBSD 9.0alpharuby25-net-ldap-0.16.3.tgz
NetBSD 9.0alpharuby26-net-ldap-0.16.3.tgz
NetBSD 9.0alpharuby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby25-net-ldap-0.17.0.tgz
NetBSD 9.0earmv6hfruby26-net-ldap-0.17.0.tgz
NetBSD 9.0earmv6hfruby27-net-ldap-0.17.0.tgz
NetBSD 9.0earmv6hfruby30-net-ldap-0.17.0.tgz
NetBSD 9.0earmv6hfruby25-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby26-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby25-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby26-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby25-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby26-net-ldap-0.16.3.tgz
NetBSD 9.0earmv6hfruby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby25-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby26-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby27-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby30-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby25-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby26-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby25-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby26-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby25-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby26-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby27-net-ldap-0.16.3.tgz
NetBSD 9.0earmv7hfruby25-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby26-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby27-net-ldap-0.17.0.tgz
NetBSD 9.0earmv7hfruby30-net-ldap-0.17.0.tgz
NetBSD 9.0i386ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0i386ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0i386ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0i386ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0i386ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0i386ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0i386ruby25-net-ldap-0.17.0.tgz
NetBSD 9.0i386ruby26-net-ldap-0.17.0.tgz
NetBSD 9.0i386ruby27-net-ldap-0.17.0.tgz
NetBSD 9.0i386ruby30-net-ldap-0.17.0.tgz
NetBSD 9.0mips64ebruby25-net-ldap-0.17.0.tgz
NetBSD 9.0mips64ebruby26-net-ldap-0.17.0.tgz
NetBSD 9.0mips64ebruby25-net-ldap-0.16.3.tgz
NetBSD 9.0mips64ebruby26-net-ldap-0.16.3.tgz
NetBSD 9.0mips64ebruby27-net-ldap-0.16.3.tgz
NetBSD 9.0mips64ebruby25-net-ldap-0.16.3.tgz
NetBSD 9.0mips64ebruby26-net-ldap-0.16.3.tgz
NetBSD 9.0mips64ebruby27-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby25-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby26-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby27-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby25-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby26-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby27-net-ldap-0.16.3.tgz
NetBSD 9.0powerpcruby25-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby26-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby27-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby30-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby25-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby26-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby27-net-ldap-0.17.0.tgz
NetBSD 9.0powerpcruby30-net-ldap-0.17.0.tgz
NetBSD 9.0sparc64ruby25-net-ldap-0.17.0.tgz
NetBSD 9.0sparc64ruby26-net-ldap-0.17.0.tgz
NetBSD 9.0sparc64ruby27-net-ldap-0.17.0.tgz
NetBSD 9.0sparc64ruby30-net-ldap-0.17.0.tgz
NetBSD 9.0sparc64ruby25-net-ldap-0.16.2.tgz
NetBSD 9.0sparc64ruby26-net-ldap-0.16.2.tgz
NetBSD 9.0sparc64ruby27-net-ldap-0.16.2.tgz
NetBSD 9.0sparc64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0sparc64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0sparc64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0sparc64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0sparc64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0sparc64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0sparcruby25-net-ldap-0.16.3.tgz
NetBSD 9.0sparcruby27-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby30-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.16.3.tgz
NetBSD 9.0x86_64ruby25-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby26-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby27-net-ldap-0.17.0.tgz
NetBSD 9.0x86_64ruby30-net-ldap-0.17.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.