net/py-aio-pika - The NetBSD Packages Collection

Wrapper for the aiormq for asyncio and humans

aio-pika is a wrapper for the aiormq for asyncio and humans.

Features
* Completely asynchronous API.
* Object oriented API.
* Auto-reconnects with complete state recovery with connect_robust (e.g.
  declared queues or exchanges, consuming state and bindings).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

net/py-aiormq www/py-yarl devel/py-setuptools lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy36-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy37-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy38-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy39-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy37-aio-pika-6.7.0.tgz
NetBSD 8.0earmv7hfpy36-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy37-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy38-aio-pika-6.7.1.tgz
NetBSD 8.0earmv7hfpy39-aio-pika-6.7.1.tgz
NetBSD 8.0i386py36-aio-pika-6.7.0.tgz
NetBSD 8.0i386py37-aio-pika-6.7.0.tgz
NetBSD 8.0i386py38-aio-pika-6.7.0.tgz
NetBSD 8.0i386py36-aio-pika-6.7.1.tgz
NetBSD 8.0i386py37-aio-pika-6.7.1.tgz
NetBSD 8.0i386py38-aio-pika-6.7.1.tgz
NetBSD 8.0i386py39-aio-pika-6.7.1.tgz
NetBSD 8.0i386py36-aio-pika-6.7.1.tgz
NetBSD 8.0i386py37-aio-pika-6.7.1.tgz
NetBSD 8.0i386py38-aio-pika-6.7.1.tgz
NetBSD 8.0i386py39-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy36-aio-pika-6.7.0.tgz
NetBSD 8.0powerpcpy37-aio-pika-6.7.0.tgz
NetBSD 8.0powerpcpy38-aio-pika-6.7.0.tgz
NetBSD 8.0powerpcpy36-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy37-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy38-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy39-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy36-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy37-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy38-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy39-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy36-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy37-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy38-aio-pika-6.7.1.tgz
NetBSD 8.0powerpcpy39-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py39-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py36-aio-pika-6.7.0.tgz
NetBSD 8.0x86_64py37-aio-pika-6.7.0.tgz
NetBSD 8.0x86_64py38-aio-pika-6.7.0.tgz
NetBSD 8.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 8.0x86_64py39-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py36-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py37-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py38-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py39-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py36-aio-pika-6.7.0.tgz
NetBSD 9.0aarch64py37-aio-pika-6.7.0.tgz
NetBSD 9.0aarch64py38-aio-pika-6.7.0.tgz
NetBSD 9.0aarch64py36-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py37-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py38-aio-pika-6.7.1.tgz
NetBSD 9.0aarch64py39-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy36-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy37-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy38-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy39-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy36-aio-pika-6.7.0.tgz
NetBSD 9.0alphapy37-aio-pika-6.7.0.tgz
NetBSD 9.0alphapy38-aio-pika-6.7.0.tgz
NetBSD 9.0alphapy36-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy37-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy38-aio-pika-6.7.1.tgz
NetBSD 9.0alphapy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy36-aio-pika-6.7.0.tgz
NetBSD 9.0earmv6hfpy37-aio-pika-6.7.0.tgz
NetBSD 9.0earmv6hfpy38-aio-pika-6.7.0.tgz
NetBSD 9.0earmv6hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv6hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy36-aio-pika-6.7.0.tgz
NetBSD 9.0earmv7hfpy37-aio-pika-6.7.0.tgz
NetBSD 9.0earmv7hfpy38-aio-pika-6.7.0.tgz
NetBSD 9.0earmv7hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy36-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy37-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy38-aio-pika-6.7.1.tgz
NetBSD 9.0earmv7hfpy39-aio-pika-6.7.1.tgz
NetBSD 9.0i386py36-aio-pika-6.7.0.tgz
NetBSD 9.0i386py37-aio-pika-6.7.0.tgz
NetBSD 9.0i386py38-aio-pika-6.7.0.tgz
NetBSD 9.0i386py36-aio-pika-6.7.1.tgz
NetBSD 9.0i386py37-aio-pika-6.7.1.tgz
NetBSD 9.0i386py38-aio-pika-6.7.1.tgz
NetBSD 9.0i386py39-aio-pika-6.7.1.tgz
NetBSD 9.0i386py36-aio-pika-6.7.1.tgz
NetBSD 9.0i386py37-aio-pika-6.7.1.tgz
NetBSD 9.0i386py38-aio-pika-6.7.1.tgz
NetBSD 9.0i386py39-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy36-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy37-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy38-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy39-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy36-aio-pika-6.7.0.tgz
NetBSD 9.0mips64ebpy37-aio-pika-6.7.0.tgz
NetBSD 9.0mips64ebpy38-aio-pika-6.7.0.tgz
NetBSD 9.0mips64ebpy36-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy37-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy38-aio-pika-6.7.1.tgz
NetBSD 9.0mips64ebpy39-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy36-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy37-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy38-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy39-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy36-aio-pika-6.7.0.tgz
NetBSD 9.0powerpcpy37-aio-pika-6.7.0.tgz
NetBSD 9.0powerpcpy38-aio-pika-6.7.0.tgz
NetBSD 9.0powerpcpy36-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy37-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy38-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy39-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy36-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy37-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy38-aio-pika-6.7.1.tgz
NetBSD 9.0powerpcpy39-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py36-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py37-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py38-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py39-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py36-aio-pika-6.7.0.tgz
NetBSD 9.0sparc64py37-aio-pika-6.7.0.tgz
NetBSD 9.0sparc64py38-aio-pika-6.7.0.tgz
NetBSD 9.0sparc64py36-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py37-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py38-aio-pika-6.7.1.tgz
NetBSD 9.0sparc64py39-aio-pika-6.7.1.tgz
NetBSD 9.0sparcpy36-aio-pika-6.7.1.tgz
NetBSD 9.0sparcpy37-aio-pika-6.7.1.tgz
NetBSD 9.0sparcpy38-aio-pika-6.7.1.tgz
NetBSD 9.0sparcpy39-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py39-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py39-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py39-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py39-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.0.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py39-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py36-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py37-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py38-aio-pika-6.7.1.tgz
NetBSD 9.0x86_64py39-aio-pika-6.7.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.